Problem using v2.78 on my Windows 7 PC.

I'm not sure what the heck is going on but v2.73 seemed to work fine on my Windows 7 PC.

After installing v2.78 on the same PC various dialog boxes (The one to link to Discogs: Check for Updates, Download update FreeDB servers) aren't launching. It's like some extra JAVA or scripting module or something similar is needed to use v2.78 on a Windows 7 PC.

I verified this by installing the v2.78 build on my 64 bit Windows 10 laptop (Using my same home network) and it worked with no issues at all. All confirm dialog boxes came up and the Discogs Dialog for entering the code popped up too.

Do I need to install some special Microsoft framework update or something to have v2.78 work on a Windows 7 PC?

Even when I click on any of the entries listed under Tag sources v2.78 pops up boxes displaying errors regarding problems connecting to the site. When using v2.73 none of this happened at all. Something had to been changed in this latest build for all of these issues to occur.

And yes, I added an allow entry in Windows Firewall for MP3Tag. Even turned my Firewall off completely and still the connection problems occur.

Please, can someone tell me what is going on here? How can I fix this? Don't want to update my Windows 7 PC to Windows 10.


I would close MP3tag,
search for the mp3tag.cfg file,
rename it (as a backup if it is not the cause)
start Mp3tag again and see if it works now.
It could be that the mp3tag.cfg file is somehow messed up.
If this does not help, delete the youngest mp3tag.cfg and rename the old file again.

Also, you should install MP3tag with the same user-id with which you want to use it.

Tried all of your suggestions and still the problem persist.

It's like the v2.78 build isn't able to talk with my default browser to launch the confirm window. Even the tag source site connection errors have me very puzzled. MP3Tag isn't being blocked at all. It's like the program is keeping itself from accessing the web.

I'm going to attempt copying the .cfg file from my Windows 10 laptop to my Windows 7 PC to see if that works.

I just want my Discogs source back to name/tag my new albums. That's it. Don't really care about the other tag sources.

Is there another way I can trick MP3Tag to launch the code box to link with Discogs so I can confirm it? Something I can type into the Windows Run dialog box. How about type directly into my FireFox browser?

Are you sure a new Microsoft framework or scripting package isn't needed under Windows 7 for v2.78 to work? Something is missing with this installation.

You could test the internet access for MP3tag with the function
Help>Check for new versions
This should result in a dialogue box if MP3tag has internet access. If you do not see a dialogue box telling that there is or is not a more uptodate version, then MP3tag is most likely blocked by the firewall.

Do you use a portable installation or did you copy MP3tag manually to the new system? Or did you install MP3tag from scratch?

If it is no installation from scratch, then it could still be that the access permission are not set properly but still feature the old user-ids and ownerships.

Is the Windows 7 system a migration from an XP system? Then in particular check the ownership of the Mp3tag folders, both in the programs folder and the %localappdata% folder.

I've tried installing v2.74, 2.75 and 2.78 (After totally removing previous install.) Only one that seems to work on my Windows 7 PC is v2.73.

Did also try the portable build too with same results. I use Revo Uninstaller Pro to totally remove previous installs before attempting a new one.

This PC came with Windows 7 64 Bit Home Edition pre-installed. Other than the hundreds of Microsoft updates performed on it over the past year, nothing has changed.

This "Help>Check for new versions" command, where do I run this in MP3Tag? Don't see any sort of option to launch such a command from a command line. Can you give me the steps?

Really curious if something on my PC is secretly blocking this 2.78 version from accessing the web. Better yet, why didn't it block the v2.73 one if it is blocking it...

No command line. As you wrote above.
MP3Tag-Menue -> Help -> Check for new versions

I referred to the Help menu. In this you find a function with a name like "Check for new versions" (I run the German version, so I had to translate it - I don't know if this is the exact translation).
This function tries to access the internet. If it succeeds, you get a message box, either telling you that you have the latest version or that there is a newer one. If you do not get a message box then MP3tag gets blocked by something on your PC.

In general: I think that this is an absolutely local problem. I have MP3tag on XP, W7, W8, W10 and it runs just like it should.
As I cannot look over your shoulder and check if it is the anti-virus program, the firewall, the access rights, you have to be the detective on your system.

Please check the locations mentioned in this thread
if you can access them, esp. who the owner of these folders is. For this create a column in the Explorer for "Owner" and see if it is just a weird sequence of numbers and letters or something that makes sense to us humans. The latter is OK then.

But as you did clean installs, the reason for the strange behaviour is more likely to be found in conflicting programs like firewalls and anti-virus programs.

You're probably right. Tried everything and nothing seems to fix this issue.

I've now upgraded my Windows 7 PC to Windows 10 and once again MP3 Tag v2.78 works perfectly on it. Guess I have to stick with the newest build of Windows if I want to use this program.

Thanks for your assistance.

I can report that I run mp3tag 2.78 on windows computers using Win7, Win8.1, and Win10, all with no issues.

You must have an issue with your personal Windows 7 installation that maybe got repaired by upgrading to W10.
I am sure you will not have this issue if you make a new clean install of W7.