Problem with "Comment" tag...


#1

Hi,

I am using version 2.28b.

I use EAC and LAME to generate my MP3s.

When I use Mp3tag to make my files even more perfect :wink:, I see the following in the "Comment" tag:

Track:comments: Exact Audio Copy\Exact Audio Copy

Is that normal?

Other tag editors see:

Exact Audio Copy

Windows explorer also sees:

Exact Audio Copy

Am I passing bad parameters to LAME?
Is this a problem with ID3 tag versions?

For debugging purpose, there is one of these files you can download and check:

http://axiomatize.com/13%20-%20Secret%20Sorrow.mp3

Thanks in advance for any help.

AND know one thing: Mp3tag is the very best tagger I found and I tested 28!!!


#2

You have two comments. In mp3tag go View>Tags and it should come up with a window (look at the attached image) and it will have all the tag info for that mp3. Just delete the comment.



#3

Thanks!

That's kind of odd. Some tracks only have "Exact Audio Copy", some of them have the two comments you mentioned.
Is EAC behaving randomly?

I will have to go in the option tab and see if I can prevent EAC from adding anything to the comment tag. After all, they already put something in the "Encodedby" tag.

Thanks for your help.


#4
Track:comments: Exact Audio Copy\Exact Audio Copy

Do you know if that type of comment formatting is specific to a version of ID3?
Or is it a proprietary extension of the "comment" tag?


#5

Actually this comment type is part of id3v2 standard.
But not many programs make use of it.
The part before the \ sign is the description part of the comment.
But Florian can explain this better :slight_smile:


#6

Thanks, dano.

If it's a legit ID3v2 tag format, is it being displayed correctly by Mp3tag?

I still have not resolved this mystery.
I mean I don't yet know how some of my tracks simply end up with "Exact Audio Copy" while others end up with "Track:comments: Exact Audio Copy\Exact Audio Copy".

I have a clue, though.

I used EAC/LAME to rip and encode the tracks initially, but I later used RealPlayer to organize them.
Maybe RealPlayer altered/re-formatted some of the tags. I will have to test that.