Problem with danish letters

Hello guys

Somehow and suddenly I get a strange behavior, which I can't solve. When I run mp3tag I create a NFO file with notepad.

In the NFO this line is present:

$loop($num(%discnumber%,3)$num(%track%,2)%_path%)$num(%track%,2)'. '$left($replace(%title%,'Å','Aa','å','aa','a°','a','Æ','Ae','æ','ae','Ø','Oe','ø','oe')$repeat($char(32),57),57)' : '[$replace(%length%,'',':')]

 $loopend()

I have added this: 'a°','a', cause suddenly it changes å too a°, which should be aa.

Can anyone help?

The NFO file is saved in ANSI, if that has anything to say.

Is that just some kind of shortcut in the description? I am sure that you cannot run MP3tag code in notepad.
Could you give an example string?
Because when I use the $replace() statement in the Converter>Tag-Tag for test purposes (preview), it replaces an awful lot of characters but I am not sure that this is what you want.

I don't see a problem with the format string. Can you double-check if the actual audio file contains the right characters?

Kind regards
– Florian

This is what it generates:

                             TRACKLiSTiNG

 01. Lys I Din Lejlighed                                       : 04:05
 02. I Mine Oejne                                              : 04:16
 03. Falder                                                    : 03:09
 04. Mer' End Kaerlighed                                       : 04:11
 05. Millionaer                                                : 04:29
 06. Vi Lever                                                  : 04:31
 07. Igen I Dag                                                : 04:09
 08. Nangijala                                                 : 03:55
 09. Ringe I Vandet                                            : 03:30
 10. Vover Pa° At Ga°                                          : 03:54
 11. Sirenerne                                                 : 04:26
 12. Under Stjernerne Pa° Himlen                               : 02:54
 
			     PLAYTiME..........: 00:47:29
			     TOTAL SiZE........: 328,20 MB

Lets take song number 10, filename is:

110-Vover På At Gå

You're replacing in the TITLE field in your export configuration, not the filename. Can you double-check the contents of the TITLE field for track 10?

Kind regards
– Florian

My bad.

This is title:
Vover På At Gå

It works as expected here. Have you tried saving the export configuration as UTF-8?

Kind regards
– Florian

Still the same. Weird. But don't think there is much to do. It's only that 1 album, so I can live with it. :slight_smile: Thank though.

http://imgur.com/a/Xw3Gc