problem with itunes

I´ve been using this wonderful programme to edit the tags on my mp3 files, that I later open with iTunes.
For the last couple of years it has worked perfect, but all of a sudden iTunes does not open my tags like commentaries. If i convert them with iTunes I can see my commentaries but then loose the genre and bpm tags.
The last time before it went wrong I only changed the album artist and from then on I have had this problem, I really need to fix this but after lots of hours I just can´t find what´s wrong.

Please can somebody help me???

Thanks in advance

If only the comment tag is missing then this could be your problem:

How is your read/wite/remove settings (ctrl+O settings dialog) for tags? make sure you work only with v2.3 as its fully compatible with iTunes. So for read tick all boxes. Write tick only v2.3 and remove tick all EXCEPT v2.3. Its sounds like your using iTunes to convert the tags to v1 which nearly completely strips the tags and leaves only very basic ones.

So once this is done take a problem file into the app.

  1. Fill your tags.
  2. Ctrl+S (save tag)
  3. Remove button (will only remove the tag type you have ticked in the options.
  4. Ctrl+S (save tag)

Open iTunes and play the file as this is the only way to update tags in iTunes is to play them. See how you go from there.

Thanks a lot Stevehero for your answer!!

I´ve tried to configure the read write remove settings lots of different ways, and now have tried the way you say, but it is still the same.
The strange thing is that before it used to work everytime ok and I had never had to change any configuration, only saved tags and that was it. I´ve no idea how or what has changed.
I only tried to use the itunes convert tag option to try and fix this, but before I had never used this. I think that you are right, it converts the tags to v1.

Thanks a lot to Dano also for answering, I will start now to look at the links you posted, I will let you know how I get on.

Great work Dano!!!
Thanks a lot, you´ve made my day!!!!