Problem with removing tags by setting to ""


#1

Since installing v2.33 the following doesn't always work to remove a tag. This worked fine prior to 2.33.

Format value "TAG": $if(1,,)

I use this is on "temporary" tags that I create as part of a mult-action action. For instance:

Format value "TMP_ARTISTSORT": %artist%
...
Format value "TMP_ARTISTSORT": $if(1,,)

I've also tried using the "Remove fields" action to do this, but this too does not seem to work in removing the temporary tags.


#2

I should probably mention that these are vorbis comments within FLAC files.

Any ideas if this is a bug, or if it's by design? Is it now possible to have blank, or zero-length strings as tag values? The odd thing is that this behavior seems to be variable. After doing the Format value ... $if(1,,) sometimes the tag is removed, and sometimes not.


#3

I've tried it with the Remove fields action and it gave the expected result.

Can you please try again and make sure that the Remove fields action is below the Format value action?

Best regards,
~ Florian

Edit: And yes: empty tag fields should not been saved at all. I'll fix this to the next release.


#4

Yes, Remove fields works. I'm not sure what I was doing previously to make me think that it did not.

Thanks.