Provide names for Unidentified Album and tracks

Hi, This is probably basic stuff but as a pretty non technical guy I need some help! My Sonicorbiter did not recognise the new Rolling Stones CD (Hackney Diamonds) on CD import (and still does not - retrying the import does not work as the album is seen as the same unidentified album) and decided it was an "unidentified album".
So my question is, what steps do I take using MP3 Tag to name the Album and the tracks? In Finder on the Mac I get an option for "open with" for the tracks, but not for the Album. Hardware is a MacBook Air running Sonoma 14.1.2 and a screen shot of the Finder info is here - I hope
image

Load all the files into MP3tag.
Select all the files.
In the tag panel: fill all the fields that get the same data (probably ALBUMARTIST, ARTIST, ALBUM, YEAR) and save the modification.
If the tracks are already in the correct order, apply the track numbering wizard.

Finally, select each file individually and set the title.

Thanks ..will try that tomorrow!

Hi,
This will seem a silly question...but here goes. I have followed your steps, using MP3Tag to correct the data for the unidentified album...but how do I put this data into the files in the Sonicorbiter? Have I missed a step or is there something else I need to do? In the Sonicorbiter this is still showing as "unidentified album".

If the player does not show the metadata but MP3tag does, then I think this is mainly a problem of the player.
It could be that the player does not support the file format at all (flac). Or the player needs a trigger to update its library and re-read the files.
Some kind of cache sometimes interferes.
One trick could be to rename the files (slightly) e.g. with an underscore somewhere which should force the player to re-read the files - and tags.
But as I said: these are functions of the player.

From my first post you will have noticed that all the music files in the Sonicorbiter are FLAC. Inspecting the album/track names in Sonicorbiter database shows the format "name" (not the quotes) for these. Looking at the Sonicorbiter data shows logged at the time of editing in MP3Tag. So I have inserted the underscores (screen shot below) but that has not changed the folder/tracks for the Unidentified Album in the Sonicorbiter. Is this something to do with the path showing in MR3Tag which is still for the same Unidentified Album? Or do I need to run the "convert"function in MP3Tag for "Tag to Filename"? It seems to me that somehow the Storage location (Unidentified Albums) and the folder name (a40b5f0c) have to get changed for this album....but how?


See the documentation on how to change (also) the filename and folder name:

I don't think that adding the underscores to the metadata contents is necessary. Also, usually the file extension .flac should not be part of the title field.

You can open one of the identified albums in Mp3tag and see if the fields are formatted in such way.

Once the metadata is in the correct format, you can use Convert → Tag - Filename to rename the files to the correct location using a format string like, e.g.,

../../flac/$replace(%artist% - %album%, ,_)/$num(%track%,2)_$replace(%title%, ,_)

Florian,
That is helpful. I will go back and re-edit the MP3Tag for the unidentified album. Below is the format for an identified album...

Yes, it's without the underscores in the metadata.

The format string I've mentioned above for renaming and moving the files to the flac folder uses Mp3tag's scripting function $replace to substitute all blanks by underscores — only while renaming, so the resulting filenames have the underscores but the metadata stays intact.

Many thanks...that worked and the files are now in the Sonicorbiter! All correctly tagged etc.

That was too good to be true! All the Albums in the Sonicorbier have a .m3u file example below. Whilst the previously unidentified album "Hackney Diamonds" is now in the database, it does not have the .m3u file and so does not show up/play in the control4 system!
Any clues as to how to overcome that?


Yes, you can use File → Create Playlist... with Paths set to Absolute.

If you need to do this more often, you can also configure the Playlist filename to use artist and album with the blanks replaced by underscore via Settings → Export → Playlist Filename set to $replace(%artist% - %album%, ,_).m3u

Hi, I now have a .m3u file for Hackney Diamonds (below), however the format is not the same as for the other albums in the Sonicorbiter (example below) and Hackney Diamonds still does not show up in my Control4 system. Any clues as to what to do?


Well, I don't understand this but....
I have a Logitec Squeezebox Server as one of the Apps in the Sonic Orbiter. I reloaded all the music files in this and restarted it...and Hackney Diamonds is there! I now have two lots of "The Rolling Stones" and "The Rolling Stones_" and the Album name is "Hackney_Diamonds_" Not sure if I can be bothered to fix that...
But the flac files are now playing in all their glory....
So thanks for all your help with this, now I will try sorting out some historic tag issues with "identified albums" with this amazing software.

1 Like

You'd need to use M3U Extended at Format when creating the playlist.

You probably have some files left where the underscore is still present in the file's metadata.