Re-tagging .mp3 to Japanese

Hey guys, I have trouble in re-tagging my mp3s to show Japanese properly. It seems that when I tried to re-tag, the details won't change and it keeps the "bakemoji" a.k.a gibberish garbage language.

Now, I'm new to this program and when I researched how to re-tag, I found this site, which I followed every step without any mistakes. However, the details won't change to Japanese characters and I'm in lost what to do...

Basically what I did in mp3tag was:

  1. Selected one of mp3 that has gibberish details
  2. Click "action" > "Convert Codepage" > Field: _ALL, Codepage: Japanese 日本語(932) > pressed OK and nothing happens...
  3. Checked that my setting was ID3v2 3 UTF -16
  4. Checked mp3tag was in latest version (v2.49b)

Also, my OS locale is set to Japanese

Ultimately, the tags for these mp3s are set in either ID3v1 (ID3v1 APEv2) or ID3v2.3 (ID3v1 ID3v2.3)

I'm not sure what more info I need to tell you guys to fix this problem but, if you need more please do tell me.

Thanks guys, help would be appreciated it.

Can you post a screenshot of your files in Mp3tag and copy some of the tags here?
Or even better if you could provide a sample file.

I'll use 4 of my mp3s as example.

Here is the screen:

For the details of the tags I've listed 2 songs below:
-01. 逆光のフリューゲル.mp3
Artist: ­·»ïÁl¡]CV¡G¤ô¾ð©`Æà¡^¡B¤Ñ¦Ð«µ
Album: TVÇ|ÇÇÇÝ “I‚¼“F°ÛdzÇïÇÑǥǪÇ|

-01 - 氣づいてゾンビさま、私はクラスメイトです.mp3
Title: ムィェナェ、ェニォセォモェオェ゙。「゙遯マォッォ鬮

A quick try for the two files that have (APEv2) in the tags:

Go to the Options > Tags > Mpeg
and enable Read [x] APE
press F5
now check if the tags are ok

If it's ok select the two files click on Save :mt_tags: to save the changes to the ID3v2 tags, too.
Then you can disable APE in the options again.

I'll check the rest later.

Yep, it worked. The tags appeared in Japanese. Now, I just need to find all those mp3s with "APEv2" and re-tag via this method. The tags are now "ID3v2.4". Also, after I'm done with re-tagging these, I need to disable APE in the options right?

As for the other one (ID3v2.3), hopefully you can give me a solution to fix it.

Thanks man.

After the APE conversion you can disable the reading again.

But you should also remove these APE tags afterwards:
Go to the Options > Tags > Mpeg
and set Remove to
[ ] ID3v1 [X] APE
[ ] ID3v2

Select the files and press Ctrl+R
This will only remove the APE tags which you don't need anymore.

For the rest of the files, I think Mp3tag cannot solve it.
I suggest you try foobar2000 with this plugin:
Try these settings:
Original charset: 932

I've tried using foobar with the settings that you recommended however, it still didn't show Japanese. I've fiddled around with it though, it doesn't seem to tag it in Japanese.

Strange, I've asked other guy the other day about this problem in different forum, and he replied back saying he was able to re-tag these files in Japanese with no problem and sent me the tagged sample files that I have sent him before (these are ID3v2.3, not APEv2). Surprisingly, the files that he tagged was in Japanese. I've asked him how to tag it but, I've yet to get replies so yeah.... apparently he used mp3tag to solve this issue.

Hmm, this is frustrating.

Is this correct Japanese?

Try all Preconversion options and leave orig charset to 932

Nope, that's gibberish. Not showing Japanese characters correctly.

I'll try all the Preconversion and see how it goes.

Nope, I've tried every preconversion but none of them shows Japanese...

Hmm, I still can't figure how the other guy was able to tag this in mp3tag. But his not replying so...

Argh, this is really pissing me off -_-;;

Bumping. Been a while but just wondering if anyone knows how to fix this.