rearrange playlist

I have a large collection of podcasts from a variety of sources.
Most include the date in the file name, but some do not. I've somehow managed to get the files into my playlist out of order, and I'm trying to figure out how to put them back in order without losing their general spread throughout the playlist.

So for example here are three files and their trackumber tags:

ry20140504.mp3 #32
ry20140430.mp3 #58
ry20140502.mp3 #60

I want to reorganise them to

ry20140430.mp3 #32
ry20140502.mp3 #58
ry20140504.mp3 #60

without changing their other tags. I can get them in the right order by sorting by filename, but then the autonumbering wizard will make the track numbers 1->2->3 rather than 32->58->60 I tried sorting them by track number, copying the tag data, resorting them by filename and then pasting, but this pastes over all the other tags which I don't want to change. I can't paste the tags in excel, and I can't figure out how to use the export function either.

You can try the following:
Open the playlist with MP3tag.
MP3tag should load the files in the order as has been defined in the playlist.
You may now move the files into such order as you like by pressing the Alt key while moving the file.

Also:
You could copy the original track number to a user-defined field, e.g. my_track with an action:
Format value for my_track
Format string: %track%

Then arrange the files in the favoured order, use the track numbering wizard to get a new ascending order.
Once you are done with playing the files in this order, copy the original track number back into the field TRACK:
Format value for TRACK
Format string: %my_track%

Once you can say something meaningful about the tracknumbers #32, #58, #60 and how they have been created originally, ... and how the binding relation between the file and the tracknumber is described, ... then you may have a chance to recreate the matching relation between the file and the tracknumber.

DD.20151127.1913.CET

I think I'm missing something here.
Won't the field my_track get rearranged with everything else when I change the order?
How do I copy the field "my_track" on its own so that I can paste it over the rearranged order?

Moving an entry in the files list about does not change the contents of any tag field, including TRACK.
So: before you do anything to the order of files in the files list, copy the contents of TRACK to MY_TRACK.
Now arrange the new order.
Then use the track numbering wizard so that you get the new order burned in.
(Alternatively, you can create a new playlist straight away.)
Renumbering the files might have the advantage that you can recreate the order of the playlist even without the playlist ...

As soon as you want to get the original track number back, copy MY_TRACK to TRACK.

I think you've misunderstood me. I won't want the old track numbers back.

I'll try to explain myself a bit better.

This is what my playlist looks like at the moment, with track numbers attached:

podcastB150430.mp3 #1
audiobook_ch1.mp3 #2
podcastA20150504.mp3 #3
podcastB150501.mp3 #4
audiobook_ch2.mp3 #5
conference_seminar_no_date_in_file_name1.mp3 #6
conference_seminar_no_date_in_file_name2.mp3 #7
podcastA20150430.mp3 #8
podcastB150502.mp3 #9
audiobook_ch3.mp3 #10
podcastA20150502.mp3 #11

The track numbers are there because I sorted my playlist by download date and then used the autonumbering wizard. They weren't originally part of the files.

I don't know why podcast A (in bold) is out of order, but it is. My end goal is to change the order of Podcast A without changing how it is spread out through the other tracks, so that podcastA20150430 goes from #8 to #3, podcastA20150502 goes from #11 to #8 and podcastA20150504 goes from #3 to #11. The playlist is excessively long, so rearranging the files individually won't work.

What I'm trying to do to reach this goal is isolate all the podcast A files, copy the track numbers, sort podcast A by filename (which will put them in the correct order), and paste the track numbers, without changing the other tags. If I go right click->Tag Copy, then when I paste, all the other tags in the files will get pasted as well. If someone can explain to me how to copy the tag data into excel and back, I will be able to do it there.

Just some thoughts ....

  1. A playlist file is in general a text file, which contains filepathnames of files to be played, ...
    where the position of the filepathname within the entire list determines the moment when the filepathname should be invoked to be played.
    An audio file which is member of a playlist does not need to have its own tracknumber, ...
    also it does not need to get a changed tracknumber, when its position in the playlist will be changed.
    The position in time to be played is given by the textual order of the filepathnames within the playlist.
    That is the advantage of the playlist, because there is no need to change any tag-data within a playlist member file, therefore the tracknumber of the file's original parent file set can be left untouched, respectively there are no distinct tracknumbers needed at all.

  2. Within the Mp3tag listview you can move a single file entry or a selected group of file entries up or down in the listview to place the selection anywhere in the listview.

  • Alt + Drag'n'Drop Change order of files in list of files.
  • Alt + Arrow down Change order of files in list of files.
  • Alt + Arrow up Change order of files in list of files.
  • Alt + Page down Move selected files to end in list of files.
  • Alt + Page up Move selected files to beginning in list of files.
    Based on the current arrangement of filenames you can create an everlasting playlist file.
  1. Now to your problem.
    You have a set of files, collected within a playlist, where you have set the tracknumber within each file to the positon number of the file within the playlist.
    This looks like a fixed compilation set of files on a CD, where each file has its dedicated place within the set of files on the data media (... therefore a playlist file is not needed, because the tracknumber determines the order!).

For filenames like ... "podcastAyyyymmdd" ... there has something going wrong, maybe because of the order of the download date of the files (file modified or creation date on the data storage), which differs from the date string within the filename.

There should be some options to clear the situation, but this depends on the amount of files to be touched, treating 3 files or 30 files or 300 files.

How did you do this within Mp3tag?
I have created a column in the Mp3tag list view this way:
Name: File Mod DT
Value: %_file_mod_datetime%
Field:
Sort by: %_file_mod_datetime_raw%
Numeric: yes

  1. A possible workflow how to solve your problem.

Step 1.
Sort the files by tracknumber.
Put the focus on "podcastA" files:
Filter: "%_filename%" HAS "podcastA"
podcastA20150504.mp3
podcastA20150430.mp3
podcastA20150502.mp3

Step 2.
Save tracknumbers to text file:
Create an export script, which outputs only the tracknumbers to text file ...
e. g. output filename: T:\TEST\20151128.hypershock\Tracknumbers.txt
3
8
11
Example for export script (only one line) ...

$filename($getEnv('USERPROFILE')'\Desktop\Tracknumbers.txt',UTF-8)$loop(1)%TRACK%$char(13)$char(10)$loopend()

Note: $loop(1) is a trick to do not sort the files by some tag-field content, but use the files in the order as is within Mp3tag listview.

Step 3.
Sort filtered list by filename ...
podcastA20150430.mp3
podcastA20150502.mp3
podcastA20150504.mp3
... and select the files.

Step 4.
Set TRACK with tracknumbers from text file.
Convert "Text file - Tag"
Filename: T:\TEST\20151128.hypershock\Tracknumbers.txt
Formatstring: %TRACK%
Preview:
"T:\TEST\20151128.hypershock\podcastA20150430.mp3" -> TRACK: 3
"T:\TEST\20151128.hypershock\podcastA20150502.mp3" -> TRACK: 8
"T:\TEST\20151128.hypershock\podcastA20150504.mp3" -> TRACK: 11
Apply the change when ok.

Close the Filter.
Sort by TRACK.
Ready.

DD.20151128.1211.CET, DD.20151128.1512.CET

I'm treating over 500 files, and the playlist overall is in the thousands.

I did basically what you did except with "file_create_datetime" instead of "file_mod_datetime"

How do I do this step?
I go File>Export>set the export file name to the correct location, but the "ok" button is greyed out. If I try "name of new export configuration" it says "File "filename.mte" cannot be created".

See post above, I have added a simple one-line export script.
You may set any name for the export script file.
You may set any other name for the export output text file.

DD.20151128.1256.CET