Refresh tags function


#1

I have an mp3 file with both ID3 tag v1 & v2 filled in with Winamp.
I use the fields: Title Artist Album Year & Comment.
In Windows Explorer I use the detailed view and I make the field Year & Comment visible.
Now the strange thing is that on some files I don't see the content of the Comment field in Windows Explorer but I do see them in Winamp, so they are there.
The only way to get this right is delete the entire mp3v2 tag and fill in again all the fields manually.

I'm wondering is there a sort of 'tag-refresh' function available in mp3tag that can do this automatic?
I have a sample file available if needed.


#2

If you highlight a file and click the Save button, I believe it will rewrite the tag, might solve your problem.


#3

Bear in mind that Windows Media Player and Windows Explorer do not support ID3v2.4 tags.


#4

I tried the Save function, it doens't do the trick.

My mp3 file has ID3v2.3 (ID3v1 ID3v2.3) tag if I look at the properties of it, in mp3tag.
Also if I look at the Metadata (alt-t) I don't see any unwanted or funny tags or so.
I think the the tag is screwed up somehow.
I find it a kind annoying that I don't see my Comments in Win-Explorer on some files.
Problem is that there is not a way to see on what files the tags are corrupted, unless checking them 1 by 1.
It really would be nice if I should can do a sort of tag-refresh on selected files in mp3tag.
How can I do this? Erasing the tag completely after first saving the content and then append the tag again with the saved contents.


#5

Is there really no solution for this?
Am I the only one with this problem?


#6

If you use the Detailed view in Windows Explorer, you can add a new column by right clicking any of the existing columns and then clicking on "Comments" or whatever the proper English name is (I use a German Windows version). In that way, you can at least see what files are affected by your problem.

BTW, have a look at this (please read the whole thread since some of the information in the first few posts is outdated): /t/3621/1


#7

That is exactly what I tried already (adding Comment column with right click) and it is like this I can't see the Comment tag on some mp3 files. I don't use a Comment on all my files so it is impossible to see which files exactly, are displaying the Comment field correctly in Explorer.
I noticed this by looking in the tags (with Winamp) to find that the comment was there already but was not displayed in Explorer. After deleting the tag an then add a new tag with Winamp or mp3tag it displays OK.
I think the ID3v2 is corrupted somehow or Explorer can't display the Comment for some reason.
A global refresh (delete and rewrite with the same used fields) of the tags looks like a possible solution to me, but can I do that with mp3tag?


#8

You can use Ctrl+R to remove the tags completely and then Ctrl+Z to write it back.

In "Tools > Options > Tags > Mpeg" in the "Remove" section you can choose what tag types are deleted when you use Ctrl+R


#9

It's unbelievable, but even with this remove/undo function, I don't get the Remark tag viewable in Windows Explorer.
The only way to see it in Explorer is to remove de ID3v2 tag in WinAmp and then re-add it by copying from the ID3v1 tag also in Winamp. But like this I loose some extra tags from the ID3v2 format AND I need to KNOW which files are like this!
After this I noticed in mp3trag that the IDtag size remains the same: 2061 Byte.

I also tried the id3clean.exe tool with -compact option but that doesn't help either.
(see post how to reduce filesize after deleting unwanted tags?
This tool can remove the unused padding in the tags, fine to reduce the filesize a little more. A shame it doesn't has a windows shell, maybe this also would be a nice feature for mp3tag to include.


#10

What language is used in your Windows and what's your Mp3tag version?
And what settings are used in "Tools > Options > Tags > Mpeg" ?


#11

I just tried with v2.39 (was 2.37b) but Ctrl+R and then Ctrl+Z (delete tag and undo) doesn't work either. I use WinXP SP2 Dutch version and mp3tag mpeg settings are: Read: all 3 checked; Write:ID3v1 ID3v2 checked, button at ID3v2.3 UTF16, Delete: all 3 checked.

I also found now that and mp3 file, made by itunes (v6.0.5, right click convert to mp3) from a m4a file has the same problem in showing the remark field with Win Explorer. Such a file has only a ID3v2 tag. If I look at it with mp3tag everything looks fine, the comment is displayed allright. If look at the tags, alt+T, I see 3 comments; COMMENT, COMMENT ITUNNORM & COMMENT ITUNSMPB. I suspect the trouble has something to do with those last 2 tags. I can remove them with mp3tag, but it doesn't help.
Until now the ONLY way to get a 'good' ID3v2 tags on such file, that shows the remark in Win explorer, is to complete delete the ID3v2 tags and make new ones (or copy from ID3v1) in winamp.
This does NOT work in mp3tag; Delete (with tags mpeg delete id3v2 checked) and Write again ( tags mpeg write ID3v1 & ID3v2 checked), the remark stay unvisible in Win explorer.

Is there a way to refresch the tags in mp3tag? Delete all old incomplete or not used tags and paddings.... only keep the remainig good tags, maybe the best way is to complete rewrite the tag section it will take longer but it will be cleaner and maybe work alright.


#12

The explanation of the problem was already posted in the link from Sebastian.

To summerize it:
In ID3v2 the comment field has a language descriptor that is 3 chars long that says it which language the content of the field is.

The problem with the explorer is that it only shows the comment if the language description is the same as the windows language or if it is undefined (XXX).

By default Mp3tag writes eng (English) as descriptor.
You can change this and make Mp3tag write nld (Dutch) so the Explorer should read it.

But if you also iTunes, there is a new problem. iTunes only shows comments with eng descriptor (maybe also undefined).

You might have to choose if you want to see comments in iTunes or in Explorer.

If you want to change the descriptor in Mp3tag, you must open the folder where Mp3tag.exe is and open mp3tag.lng
Then search for _M_STR_ID3V2LANG eng
and change to _M_STR_ID3V2LANG nld
or _M_STR_ID3V2LANG XXX


#13

Thanks a lot m8, that was the answer I was lookin' for.
Sorry I didn't see it at first in the link in the post from Sebastian.
Ooh how I love this site.
I was afraid I wouldn't find an answer to this one, but know I did, at last.