Regex in the converter

If I use
$trim($regexp(%unsyncedlyrics%,'submitted by:.*$',))
in the converter Tag->Tag for UNSYNCEDLYRICS, the preview shows me, that it works as intended:
"submitted by:" and characters after this are deleted.
But when I execute it, nothing has changed.

If I use the same string in an action of the type "Format Value", it works as intended.

Bug or my limited knowledge about regex or MP3tag?
Does this not work in the converter and the preview does not know? :wink:

I tried to reproduce your observation and failed.

For simplicity, I just copied the first paragraph from your post into the field UNSYNCEDLYRICS which then has even 2 "submitted by:" parts.

The preview shows that the result would be
"xxx||If I use
$trim($regexp(%unsyncedlyrics%,'"
which is what I would expect.
After execution (or "OK") of the converter, the field UNSYNCEDLYRICS shows exactly that what the preview showed ...
as I said, I could not reproduce it.

To confirm my observation I now did the same as you did.
I still can reproduce it and also after a restart of Mp3tag.

Mp3tag, 2.99a
Windows 10 Pro, Version 1903 (Build 18362.418)

What happens if you close MP3tag, rename the mp3tag.cfg files and restart MP3tag (to get a clean cfg file)? Any better?

5h later: tried it on a different PC (W10, V2.99a as well) and found only the correct behaviour

Well, that's getting even more mysterious.
I restarted Windows. Mp3tag behaved still the same.
I started with a clean cfg-file. Mp3tag behaved correctly.
I took my renamed older cfg-file again. Mp3tag behaves correctly, too.

I once had an incident with the library - that had to be rebuilt as it would not accept any changes any more
But I do not think that my observation could have been of any use for you.
Good you got a working MP3tag again.