Remove APEv2 tags

I am trying to remove just APEv2 tags from my .flac files leaving the ID3 tags intact. I have ticked the 'remove APE' box in options-tags leaving the 2 boxes for ID3 v1 & 2 unchecked. However when I then click the 'remove tags' button all tags are deleted. What am I doing wrong?

if you've set the read/delete/keep settings approriately you would select the files then click the big red X in the menu bar (right next to the save icon). This would read, remove, and keep as you've set.

But I'm a bit confused. This is how it works for me with mp3 files. but with FLAC files, they shouldn't even have ID3 or APE tags. They should have FLAC tags (called Vorbis Comment tags). Do you actually have ID3 and APE tags within your FLAC files?

I've never heard of Vorbis Comment tags! How do I tell what type of tags they are?

My issue is that I've just started using Asset as my UPnP server and that displays information differently from that shown in MP3tag e.g. an album title will be displayed as 'title, disc 1' when the tag as shown in MP3tag is just 'title'. I've read that Asset uses APEv2 tags in preference to ID3 so that's why I was trying to delete them.

You're confused? Not half as much as I am.

I use dbpa for ripping myself. If you ripped files with dbpoweramp they should have correct FLAC tags (i.e., VORBIS COMMENT tag type). Anyhow, easy to check:

  1. in mp3tag, right click on column heading area, then select CUSTOMIZE, then NEW to create a new column
  2. in the popup box, give the new column heading the following info:
    Name: Tag Type
    Value: %_tag_read%[ (%_tag%)]
    leave field and sort by blank and do NOT tick "numeric"
  3. in left side of popup (tag visibility) make sure that TAG TYPE is ticked.
  4. Then load up your files in mp3tag and in the "tag type" column you should see "FLAC (FLAC)" If you see APE or ID3 in that column along with FLAC then you somehow have ended up with the wrong tag types also included in your files. You should ONLY have FLAC tags.

I suspect your issue with ASSET is some setting within Asset regarding how it diplays multidisk albums. But not sure as I don't use ASSET.

Thanks for this helpful reply. Done that and, yes, I do only have FLAC tags. But I'm still confused. Where will ASSET be getting its information about multi-discs from if not the tags? Presumably dbpa includes a tag that Asset then uses to display the disc number but I can't see that in MP3Tag.

Maybe I just need to stop obsessing about this!

Di you look in the extended tag-View (ALT-T) for all embedded tags?

all sorts of settings re what ASSET does. You will be best asking your question over at the dbpa/illustrate forums.

one point....do the files have the DISK tag field filled in with a "1". Try deleting the disk field from a couple of albums that you see this on. Then do a complete rescan of your music files in ASSET. Check those albums again. Does it display disk number along with title? You can do this by looking at files within mp3tag, right click, select "extended tags" and you'll see all tags.

p.s. don't select all files and remove Disk Tag for all of them. For some albums you WANT the disk tag (disks with more than 1 disk in the album).