Remove FLAC ID3v2


#1

MP3TAG reports that most of my flac files have only FLAC (FLAC) tags (Vorbis Comments). For some of my flac files MP3TAG reports that they have FLAC (FLAC ID3v2) tags. Is it possible to remove, or change, the ID3v2 bit of the tags in flac files using MP3TAG and how is this done?


Tags: FLAC (FLAC) and FLAC (FLAC ID3v2)
#2

Select the files, right click > Tag Cut
Then right click > Tag Paste

This is also possible with Ctrl+X and Ctrl+V

It removes both FLAC and ID3v2 and pastes FLAC back.


#3

I have already tried that, but it did not work. It did not remove the ID3v2.3 bit (it still says (ID3v2.3) as tags), and a paste restores all tags to FLAC (FLAC ID3v2.3), minus the embedded cover art.


#4

Bump.

Any new ideas?

Or is it just that MP3TAG currently cannot read or write ID3v2 tags in flac files, only detect them and report that they are there?


#5

Well it works for me, I also get the cover art back.
Maybe you can provide a sample file?


#6

I tried it again with the same result, except that the cover art was pasted back this time.

In the settings I have:
MPEG
Read: ID3v2.3
Write: ID3v2.3 ISO-8859-1
Remove: ID3v1 and APE (I have tried selecting also ID3v2.3 with the same result)

APE, MPC...
Read: ID3v1 and APE
Write: APEv2
Remove: ID3v1 and APE

I use v. 2.44 final (no beta)


#7

I tried to replicate this, but can't get MP3Tag to write an ID3v.x or ape tag to a flac file. (IMHO a good thing - but a problem here).
I tried writing ID3vX tags and ape tags to an MP3 file. That worked - and, indeed cut/paste of the tags does not cause Ape to stop being the primary place tags are coming from.

Just to see, I tried dbPoweramp's converter to re-encode the mp3 file. Ape tags are no longer listed in the tags column. The same thing works for getting rid of id3 tags. I don't recommend this solution for mp3 (re-encoding is going to lose information) but it should work for flac files.
The converter is free, win-only software, BTW...

Oh - and it's probable that there are actually no ape tags after the cut/paste and there's just an ape tag container in the file.