remove ID3 v1 from end of mp3?


#1

as the title implies i have a bunch of old mp3s i'm trying to archive/sort/clean-up...
(i've had some of them since the late 90s, Xing Audio Catalyst for the win!)

Unfortunately I'm noticing that mp3tag is failing to remove ID3 v1 tags from the end/back of the mp3 files

can i submit this as a feature request?

anyone know what other method i can use to remove these tags? (via hex editor perhaps?)


#2

What have you tried so far?
Have you set Extras>Tools>Mpeg
to read and delete V1 but not to write?
Try then to remove and paste the tags with the functions from the context menu


#3

it doesn't even see the id3v1 tag.... for any of them....

see attached screen shot for details



#4

Have you tried one of the correcting tools like mp3val or the utilities in foobar2000?
Sometimes these report "Garbage at end" and are able to remove it. The data in that garbage is lost, though.


#5

downloaded mp3val.

mp3val stated for every file:
"Garbage at the end of the file"
and
"#### MPEG frames (MPEG 1 Layer III), no tags, Xing header"

and it was capable of fixing every file at the click of a button...
and every file seems to play (or at least skimmed through) flawlessly afterwards...
and every file could successfully be re-tagged using mp3tag

thank you ohrenkino for your great advice


#6

great that it worked.
honestly, sometimes at the end of a long day you simply relish such a warm thank you.


#7

I have a related question (i believe). I ran MP3val and found no issues. It's entirely possible i have no problem...well no problem with my music files! Anyway what does "id3v2.3 ( id3v1 id3v2.3)" mean? I am assuming (as a search here reveals nothing) that it means that i have multiple versions of my tags tagged to my music. Is this the case? I have mp3tag's mpeg setting set to "read"> all checked, "write"> ID3v2 ID3v2.3 UTF-16 checked, "remove"> ID3v1 APE checked. Again i'm assuming, shouldn't that remove everything but ID3v2.3 and read something like "ID3v2.3" in MP3Tag instead of "id3v2.3 ( id3v1 id3v2.3)" ?

Thanks
Tom


#8

If you have a column that shows you these 2 tag versions then this is probably due to the fact that you have the value defined as this:
%_tag_read%[ (%_tag%)]

The tags work like that APE>V2>V1.
So, if you have V2 tags in a file then only these show (with your settings).
You could run a test and switch off in Tools>Tags reading the V2-tags - you should then see the V1 tags - and their contents could be very different from the V2 tags.
So, if you want to get rid of the V1 tags then you should switch only reading and writing for V2 tags.
Deleting should be enabled for all kind of tags.
If you want to get rid of the V1 tags then cut&paste the tags with the above mentioned settings.
This may take a while.


#9

Thank You Very Much.
I am not sure i understand completely. If i have my setting set to:

Read - all selected
Write - ID3v2 & ID3v2.3 UTF-16
Remove - ID3v1 & APE

Then shouldn't all ID3v1 & APE tags be removed? With these settings ID3v1 tags are still there even though i have ID3v1 set to remove.

  • Tom

#10

Tag removal does not happen automatically when saving.
You must click on "Remove tag" ( :mt_delete: ) on the Tool bar.


#11

Aaaah, i get it. I was always afraid of the remove tag function, as i didn't want to lose my tag information. I assumed, as the name implies, that it would remove the tag information from selected files (not necessarily true). I now see that it removes tags as per the mpeg settings. A more intuitive process would be for the mpeg settings to take effect on a save, eliminating an extra step and performing as the dialog boxes imply. After all, the mpeg dialog box writes tags (when selected) automatically why wouldn't it remove tags (when selected) automatically? But that's just me.

Thanks for the help,
Tom