Removing APE tags

I'm using Mp3tag v2.45a under Windows XP.

I received some MP3 files whose tags are ID3v2.3 (ID3v1, ID3v2.3, APEv2). I would like to remove the APE tags while keeping the ID3 tags, but I can't seem to make Mp3tag do that.

Under Tools / Options / Tags / Ape, Mpc, in the "Remove" box I un-checked ID3v1 and ID3v2 and checked APE. This ought to do it, right?

However, if I select a file and hit Ctrl-S (Save tag), nothing happens: the APEv2 tag is still there. On the other hand, if I hit Ctrl-R (Remove Tag, the big red X) then all tags are removed, including the ID3v1 and ID3v2.3 tags which I wanted to keep.

Please help.

mp3 tag settings are at Options / Tags / Mpeg

I was just about to write here about ape tags not being removed on mp3 files. The apev2 tags that I found on some mp3 files are not removed, even though it's specified in my options. (Under Tags;mpeg - Write: id3v1 and id3v2 checked, apev2 - not checked; Remove: ape - checked.) Actually, the tags can't be changed or updated at all, save is grayed out. Using ver. 2.45a. I guess it's a bug?

You're absolutely right, Dano, but that is certainly confusing: To use Mp3tag to remove APE tags from my MP3 files, I shouldn't look under Options / Tags / APE but instead under Options / Tags / Mpeg.

So I repeated my original experiment, but this time I went to Options / Tags / Mpeg and under Remove, I un-checked ID3v1 and ID3v2. Again, clicking Ctrl-S (save tags) did nothing, but clicking Ctrl-R (remove tag) or clicking the red X removed the APE tags while leaving the ID3 tags alone, just as I wanted.

Thanks, Dano, for guiding me through a confusing Options dialog.

Dear j8ee, I think that my experience and dano's answer combine to answer your question. I think your settings are right, but in order to get rid of existing APE tags, "Save Tag" isn't what you need to invoke; instead you need to invoke "Remove Tag."

Let us know if that works for you.

Hmm, when I execute a script/tool, for example retagging from filename, I expect the tag fields to be filled with what I specify, and the correct tag format to be written as configured. As it is now, it doesn't work.

Referring to your screen shot, in the left-column menu, move up one item to select Mpeg instead of Ape, Mpc .... That was dano's suggestion which worked for me.

... The last screenshot got pasted twice. It should show the mpeg settings first.

How it was supposed to look:

This is indeed confusing for anyone new to the program, and often for veteran users as well. I suppose requiring the use of the explicit "Remove Tags" may be considered safer, so that may be why the program persists in doing things so awkwardly and confounding just about everyone who has used Mp3tag.

A welcome option would be a setting to "Remove designated tags when saving".