Removing numbers in the title


I used the "Filename - Tag" option to fill in the "Title"field, however the files are numberd, like 01 Alpha ,02 Beta, 03 Gamma etc. Regretable the numbering als appears in the "Title"field.

An other option i used is to Import an txtfile with titles, as result that all the names appears in one "Title"field.

Can somebody, please explain to me, (if this option is available) how to solve this problem??

Andre Linoge

How do your filenames lool like?

General help is here:

Replace with Regular Expression

Field: TITLE

Regular expression: ^\d{1,2}\s?

Replace matches with: should be left empty

That will remove one or two digits plus an optional space at the front of the title

I regret to say, this option didnt work, but i keep looking to find the solution.

Perhaps a little less sophistication may help
Stick to the "Replace with regular expression" action for TITLE
Enter as search string: ^\d\d
Enter as replace string:
(leave that empty; please note that there is a blank behind the last \d - does not show in the browser)

This expression should remove all 2-digit numbers followed by a blank and that are at the beginning of the string of the field TITLE.

Curious, it worked for me when I setup a test group with all combinations of leading numbers, with and without a sperating space

Curious here aswell, i used both expressions on the "album" field and the "artist" field and both expressions wokded fine, exeped on the "title"field no suck luck.

The problem is solved: In the window to select the action is the title displayd like "% title%", after removing "% ", the action workes just fine.