Runtime error when using right-click tools

bug-fixed

#1

Hope someone can help me out.
When i right click a song and go to tools menu , i get a runtime error
file: y:\projects\mp3tag\mtmmainframe.cpp
line: 5251

i have a couple "tools" setup and they are all doing this.

this started when i upgraded to 2.88h from 2.78

any sugestions?


#2

Perhaps you rename the mp3tag.cfg and see if a fresh start with that leads to a more glitch free performance.
(Rename so that you can re-use it if that did not remedy the cause)

Another attempt would be: rename the tools.ini file and then (after a restart of MP3tag) create a new tool and see if it works. If that is the case, then the tools.ini is corrupt for whatever reason and you have to create the tools anew.


#3

Can you post the details of the tool configuration and the complete filepath of the file that triggers this error?


#4

Thanks for the quick responses.

I tried the re-naming of mp3tag.cfg and tools.ini and had same error after making a tool again.

on a different computer i installed 2.88a and tools worked. I then installed 2.88h and am having same error

here are 2 of the tools from the tools.ini
I aslo tried directing thru to firefox and opera and neither worked.
I aslo tried just building a tool to open /windows/notepad.exe without any parameters and same error(worked on 2.88a)

[#0]
MTTOOLSNAME=google-coverart
MTTOOLSPARAM=http://www.google.com/search?q\u003d"$replace(%artist% %album%, ,+,&,+)"&tbm\u003disch
MTTOOLSPATH=C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
MTTOOLSINST=0

[#1]
MTTOOLSNAME=Discogs-artist
MTTOOLSPARAM=https://www.discogs.com/search/?q\u003d"%artist%"&type\u003dall
MTTOOLSPATH=C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
MTTOOLSINST=0


#5

OK, the tools are working here. Are the files on a special drive/NAS?


#6

Originally files were on a network drive, but moved them to the local desktop and get same error.

I will install on another computer that has never had mp3tag installed and see what that gets me.

I guess I can try the portable install too to see if makes any difference..

It will be a day or 2 before I have time to check, but will report back

Thanks


#7

(forget my last post tested from the wrong folder.)

Anyways, i retested , and the errors are only coming when the files are on my network drive.
I went back and tested the different betas.
2.88e test ok
2.88f runtime line 5260
2.88h + 289 runtime error 5251

is this a bug or is this a problem just on my network?
I am using an "Unraid" samba share

if you need me test anything, just let me know


#8

I've fixed the issue with Mp3tag v2.89a.

Thanks for reporting and testing!


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.