Sandisk Sansa 260 files not recognized


#1

I have a SanDisk e260 and MP3TAG doesn't recognize the files I have tried SanDisk's suggestions but there are none for the 260 specifically. When tried the other versions method they didn't work. Primarily they seemed to address the USB mode; but I tried MTP and there appeared to be no mp3 files in the music directory. When tried MSC MP3TAG says: "No items match your search." I can't even drag and drop or paste the files into the programs directory. I tried pasting the files onto my HD but they still weren't recognized.


#2

I doubt that the program's directory is the correct place to copy&paste audio files.
When do you get the error message as I doubt that this actually a MP3tag message - MP3tag does not search.

How ist the Sandisk treated by the OS? As a media device or as drive?
Does any other program have access to the files? Does the WIndows Explorer have access to the files?
How did the files get onto the Sandisk in the first place - surely there must be an original that can be edited, right?
In general: I doubt that this is a MP3tag problem but has to do with the way your device connects to and is recognized by the PC.
Perhaps this thread can help:
Using MP3Tag with Zen X-Fi

Or, on a completely different level: have you set a filter?


#3

Mp3tag does not support MTP mode. Only USB/MSC mode.

And if you have added files to the player on MTP mode, they also cannot be seen in USB mode.
You must add the files again in USB mode.