Seit 3.00 sind die eingebundenen Cover weg

Seit Installation der Version 3.00 gibt es Probleme mit meinen eingebundenen Covers - sie sind nicht mehr da!
Unter "eingebunden" verstehe ich, dass ich mit "Cover einfügen" eine Bilddatei (.jpg) für z.B. ein Album wähle und dann speichere. Das hat bisher auch prima geklappt.
Seit 3.00 stelle ich immer wieder fest, dass bei vielen der so bereits bearbeiteten Dateien nun keine Covers mehr vorhanden sind.
Alles neu zu bearbeiten halte ich für schlimm. Es sind ca. 1500 Alben, d.h. mehr als 25000 Einträge.
Kann das mit der neuen Feature "Albumgröße anpassen" zusammenhängen?
Danke für eine baldige Antwort.
Rita Tönne

mit einem Filter
%_covers% MISSING
kann man die Dateien finden, bei denen keine Bilder eingebettet sind.

Dann: bitte mal checken, welche Tag-Versionen in den Dateien vorhanden sind, wobei speziell APE Tags von Interesse sind, da die oft Probleme verursachen, wenn die nicht mehr mit den ID3Vx Tags synchron sind - MP3tag stellt bevorzugt APE-Tags dar.
Hiermit zusammen hängen die Einstellungen in
Extras>Optionen>Tags>Mpeg
für APE: nur Löschen sollte angehakelt sein, Lesen und Schreiben nicht.
Wenn die Einstellungen anders waren, speziell das Lesen für APE an war, dann bitte jetzt noch mal alle Dateien laden und erneut auf Abwesenheit von Covern prüfen.
Wenn jetzt immer noch welche fehlen, dann waren die vor 3.00 auch nicht da.

  1. Vielen Dank für die prompte Antwort. Der Filter-Tipp ist natürlich Gold wert.
  2. Die Kontrolle meines kompletten Einzel-CD-Bestands ergab, dass die von Ihnen genannten Bedingungen erfüllt (s. Screenshot).
  3. Die Anwendung des Filters zeigte, dass ca. 6% der Dateien kein Cover mehr enthielten. Dazu gehören seltsamerweise einzelne Tracks in ansonsten bebilderten Alben. Stutzig bin ich ja vor allem deswegen geworden, weil einige meiner liebsten Alben, deren Cover ich immer beim Abspielen sehen konnte (mit Winamp), plötzlich keine mehr hatten. Es stimmt also nicht, dass sie vorher keine hatten. Auch, dass einzelne Spuren kein Cover enthielten, ist mir unerklärlich, weil das Einspeichern immer am Ende der Bearbeitung mit einem globalen Markieren vorgenommen wird.

Nun mache ich mich an das Vervollständigen meiner Dateien.
Vielen Dank für die Hilfe.
Rita Tönne

Man kann sich die Arbeit vielleicht etwas abkürzen:
Ich würde wie folgt vorgehen:
alle Dateien laden
keinen Filter anwenden
alle Dateien markieren
eine Aktion (Quick) einrichten vom Typ "Cover exportieren" und als Format-String für den Namen festlegen: %album%
Aktion ausführen (OK drücken)

Dann:
Dateien markiert lassen
Aktion (Quick) vom Typ "Cover aus Datei importieren" wählen und als Format String für den Dateinamen: %album%.jpg, bestehende Cover überschreiben
Aktion ausführen.
Dies importiert die gerade exportierten Bilder wieder zurück in alle Dateien, wo der Bild-Dateiname dem ALBUM entspricht - und auch in Dateien, wo zuvor kein Cover enthalten war, was dann vielleicht für die Alben gut ist, wo nicht alle Dateien ein Cover abgekriegt hatten. Jetzt müssten sie eins haben.

Jetzt noch mal den FIlter anwenden:
%_covers% MISSING
Dies zeigt alle Dateien, die nun wirklich kein Cover hatten und auch keines im Album-Ordner zu finden ist. Die müssten dann noch von Hand komplettiert werden. Und das sind hoffentlich wenige.

Das ist ein Klasse-Vorschlag! Zwar habe ich inzwischen mit Fleiß und dem brauchbaren Filter alle verloren gegangenen Cover eingefüllt. Da ich aber dem Frieden nicht traue (es waren viele dabei, von denen ich mit 100%iger Sicherheit weiß, dass sie vorher schon da waren), werde ich mir in meine reiche Aktionen-Sammlung entsprechende Aktionen fix und fertig zum Aufrufen bauen, damit eventuelle Verluste mich nicht schrecken können. Danke dafür.
Sollte Ihnen vielleicht irgendwann mal klar werden, warum dieses Phänomen auftritt, würde ich mich über eine Nachricht freuen.
Einen schönen Abend wünscht Ihnen
Ihre Rita Tönne

MP3tag behandelt Daten eigentlich sehr verlässlich.
Von daher liegt für mich die Vermutung näher, dass die Bilder nie in den Dateien waren. Ggf. wurde in der Vorschau das Bild aus dem Ordner gezeigt und es wirkte so, als wäre schon ein Bild in der Datei vorhanden.

Winamp hat meiner Ansicht nach eine eigene Datenbank und sucht manchmal auch selbst Bilder aus dem Internet. Dann zeigt der Abspieler ein Bild, aber es ist nicht eingebettet.
Hier hilft nur, in regelmäßigen Abständen die Sammlung mit geeigneten Filtern auf Konsistenz zu prüfen.

Um es vorweg zu nehmen: ich bin ein Fan von Mp3tag und genieße jeden Tag, an dem ich mit dem Programm arbeiten darf. Außerdem hat es mir die Möglichkeit gegeben, meine Musikbestände mit Standard-Software wie in einer Datenbank zu verwalten und genießen.

Deshalb finde ich es schade, Ihnen dieses Mal widersprechen zu müssen. Ich verlasse mich nicht auf Bilder, die Winamp anzeigt. Sehr viele Cover habe ich außerdem selbst entworfen, wenn ich aus Einzelwerken gewünschte Alben zusammenstelle. Die kenne natürlich nur ich. Außerdem arbeite ich ja in Mp3tag mit Anzeige des Front-Covers im Panel. Daher habe ich ja überhaupt erst gemerkt, dass erstaunlicherweise manchmal keins angezeigt wurde. Teilweise gab es sogar die Anzeige "Unterschiedliche Cover" bei Alben, die ich erst vor Kurzem bearbeitet hatte, weil einige Tracks das Cover hatten, einige nicht.

Was die Verlässlichkeit von Mp3tag angeht, bin ich durchaus Ihrer Ansicht.

Es gibt aber noch eine andere Stelle, an der ich keine sicheren Ergebnisse bekomme: bei meiner Art, Playlists für die einzelnen Komponisten auszugeben. Da erhalte ich unterschiedliche Ergebnisse, wenn ich mal den gesamten Datenbestand auswerten lasse (765 Komp.), mal in Teilen (869 Komp). Mit anderen Worten, ich kann die Zuverlässigkeit des Ergebnisses dadurch steuern, dass ich die Größe des geladenen Datenbestandes variiere.

Dass ich Ihnen diese Dinge so intensiv schildere, ist mein Versuch, eventuelle Schwierigkeiten aufzuzeigen und mit Beispielen zu unterstützen. Es ändert nichts an meiner Liebe zu Mp3tag!!!

Freundliche Grüße
Rita Tönne

Ohne an der Qualität von mp3tag rütteln zu wollen ist ein gesundest Misstrauen und ein Backup immer gut!

Vor allem wenn - aus irgend einem grund - plötzlich etwas anders ist als zuvor, ist dies m.E. nach schon einen genaueren Blick wert bevor man einfach alles korrigiert.
Klar, kann ein Layer8 gewesen sein, aber aufgrund der Infos hier 50:50 :slight_smile:

Backups habe ich in rauhen Mengen und zu mehreren Zeitpunkten. Im geschilderten Fall hatte ich den ganzen Bestand an anderer Stelle intensiv überarbeitet und stellte plötzlich fest, dass Datensätze die vorher vorhandenen Cover nicht mehr hatten. Die benötigten .jpg-Dateien hatte ich natürlich albumnah im aktuellen Bestand gespeichert (außerdem natürlich in allen Backups!). Ärgerlich war ja hauptächlich, dass erneut Arbeit in die Korrektur gesteckt werden musste. Dabei war dann der Filter %_covers% MISSING sehr hilfreich.
Ich hätte nur gern den Grund gewusst, warum so ein Problem auftreten kann.

Nochmal: meiner Liebe zu Mp3tag tut das keinen Abbruch.

Gibt es denn Gemeinsamkeiten zwischen den Dateien ohne Cover (mit der Ausnahme, dass die alle ohne Cover waren)?
Wie verhalten sich die zuvor Dateien ohne Cover nachdem Cover hinzugefügt wurden? Sind wieder Cover aus diesen Dateien verschwunden?

Es ist extrem schwierig aus der Ferne ohne konkrete Datei, die reproduzierbar den Fehler zeigt, eine Fehlerursache zu ermitteln.

Da gibt keine für mich erkennbaren Gemeinsamkeiten. Das ist ja der Grund, warum mich das Ganze so irritiert. Inzwischen wird es noch mysteriöser. Beim Nachforschen in alten Datensicherungen konnte ich bestätigt finden, dass die Dateien (ich habe nicht alle untersucht) durchaus Cover hatten. Ich habe extra mal eine ältere Version von Mp3tag installiert und weiß deshalb, dass es offenbar nicht mit v3.00 zusammenhängt, ich aber erst jetzt den Verlust bemerkt habe.

Die korrigierten Dateien sind z.Zt. stabil.

Ich werde die Zustände weiter beobachten und eventuelle Erkenntnisse hierhin melden.
Vielen Dank für Ihr Interesse.