Seltsame Anzeige in Squeezebox


#1

Hallo,

ich hab folgendes Problem: wenn ich meine FLAC-Musikdateien auf eine externe Festplatte überspiele und dann 1) per mp3tag alle eventuell vorhandenen Tags entferne (Datei/Tag entfernen) und dann 2) mit einer Formel aus dem Dateinamen die Tags einlese, dann funktioniert das eigentlich auf den ersten Blick auch.

Nur: wenn ich dann die Musikdateien über meine Squeebox (WLAN-Player) abspielen will, passiert Folgendes: der Player erkennt zwar alle Dateien und wenn ich die Dateien unter "Album" anwähle, finde ich auch alle Alben. Wenn ich allerdings die Dateien unter "Interpret" anwähle, sind viele Dateien nicht da...

Ein Beispiel: auf einem Interpret-X-Album singt ein Interpret zwei Songs mit einer anderen Sängerin, der Interpretenname ist daher bei diesen beiden Songs nicht "Interpret X" sondern "Interpret X featuring Interpretin Y". Auf dem Player wird nun unter "Interpret" der Interpret X angezeigt, auch das Album ist da, nur fehlen die 2 Songs mit Interpretin Y. Soweit kein Problem und auch logisch richtig, würde der Player darunter Interpret X featuring Interpreting Y anzeigen. Nur: das macht er nicht...

Hat da jemand eine Idee: da sind die Dateien ja (ich find sie unter "Album") aber irgendwie werden sie unter "Interpret" nicht angezeigt.

Danke


#2

Kannst Du mal die Formel hochladen, damit man sieht, welche Datenfelder ausgefüllt worden sind.

Der LMS schaut sich nur eines von den Feldern "Interpret" bzw. "Album-Interpret" an. Soweit ich weiß, wird die Änderung vom LMS nicht sofort übernommen. Da musst Du schon bewusst die Datenbank aktualisieren.

Eberhard


#3

Danke für deine Antwort.

Meine FLAC-Dateien haben alle das Format 01_Titel_Interpret_Album, also z.B. 01_Mercy Street_Peter Gabriel_So.

Die Formel die ich zum Einlesen der Tags in die FLACs verwende ist:
%track%%title%%artist%_%album%

Bezüglich deines Hinweises auf den LMS: wie meinst du das, dass LMS nur eines der beiden Felder "Interpret" und "Album" anschaut und das dass nicht sofort übernommen wird?


#4

Der LMS durchsucht die Datenbank nur zu den Zeiten/Abständen, die Du in den Einstellungen "Erweitert - Musiksammlung erneut durchsuchen" eingestellt hast. Wenn die Automatische Suche dort schon ausgestellt ist wird auch nicht aktualisiert. Wenn dem so ist, also erst einmal die Datenbank aktualisieren.

Ich habe nicht gesagt, dass der LMS sich entweder Interpret oder Album ansieht, sondern Interpret oder Album-Interpret. Möchte aber jetzt fast wetten, dass er den %artist% einliest.

Wenn der LMS einige Interpreten nicht erkennt, sind es zufällig welche mit deutschen Sonderzeichen wie Ä,Ü,Ö,ä,ö,und ü? Da hat LMS schon mal bei mir Probleme.

Ist der 'Interpret X' in dem Tag "Album-Interpret" und 'Interpret X feat. Interpretin Y' im Tag Interpreten eingetragen, oder ist Album-Interpret leer?

Wir sollten nämlich versuchen, herauszufinden, ob das ein LMS-Problem oder ein MP3Tag-Thema ist. Bei einem LMS-Thema solltest Du das Thema im Squeezeforum deutsch posten. Die sind da genau so nett wie hier :wink: . Haben mir schon häufiger geholfen.

Eberhard


#5

Hallo,

vielen Dank für deine Hilfe, läuft jetzt alles rund.