Several lines in "comment"

Hello
I'm trying to add some "extra comments" but it doesn't work.
I explain :
I have some albums of John Coltrane (yeaah!) and I want to add in the comment field the name of the musiciens.

Ex :

John Coltrane — tenor saxophone, soprano saxophone
McCoy Tyner — piano
Jimmy Garrison — bass
Elvin Jones — drums

with the returns (new lines)

I tried to create a new field "Comment_add" but it's very difficult to merge the "Comment_add" with the "Comment".

So my question is : how can I put the information of the new line in the "Comment" field ? (when I look at the comment in Winamp, all is in 1 line.)

Am I clear? (I'm french :wink: )

You can enter a new line in the comment field, if you press Ctrl-Enter.
Whether this heals Winamp, I am not sure as this would require Winamp to handle the control characters for linefeed and carriage return.

thank you for the answer
carriage return isn't SHIFT-ENTER ?
whatever, it doesn't work. "Comment" field is on 1 line (on the left window) and the combinaison of keys in this fied doesn't work (not "multiple lines")
I tried "\n" but :frowning:
Winamp can read multiple lines in the "comment" field, because we can edit it with carriage return

more details :
I have created a new field in the window on the left : "Comment_Add"
I can merge this value and the "Comment" value in the main window, with columns
BUT the information of the carriage return is lost when the merge is done (in the "comment" columns, all is in 1 line) and I don't see the "Comment_Add" value when I look at the comment in Winamp

I do not care a lot about Winamp. Perhaps you are trying something that Winamp simply cannot do.

But: does MP3tag show COMMENT the way you want it after you have merged the two fields?
(BTW: how do you do that? I did it with an action of the type format value and it did just that: merge COMMENT and COMMENT_ADD including all linefeeds).
It may be necessary to merge the fields either by action or in the extended tags dialogue to get the full picture.

Winamp can read the carriage return and we can write carriage returns

no, because the "Comment" field is not with multiple lines, only 1, so the carriage returns disappeared

  • In the "Tools/Options/Tag panel" : Add field and I named this in the filed "Field" : "COMMENT _ADD" (the space after the word "COMMENT" is added by the soft (??)
  • In the Field "Name" : "Comment _add"
  • right click in the columns / Custumize columns"
  • chose "Comment" and in the value : "%COMMENT% %COMMENT _ADD%"

I don't understand, sorry
You mean I go to create a "function"?

I think the only way to save my life is to build a V 2.6 with a textarea in the "comment" field, so the multiple lines would be allowed, and no more with a simple "text" :wink:

Use "View > Extended Tags" to edit the multi line comment field.

the "OK" button has the focus, so if I press the "Enter" button, the windows close

Use Ctrl + Enter for line breaks.

Yes, as this is the least harmful default option after you have first opened the dialogue.
How is MP3tag to know which field you want to edit/delete or create a new one? You have help MP3tag a little and ...

select the field that you want to edit.
press the "Edit button"
enter the modifications in the subsequently opened dialogue
finish the editing with OK
press OK to apply the changes.

As for the "functions" that you do not know how to create: first of all it is "action" - you will find a separate menu for this.
Secondly, there is a guide in this forum in the FAQs how to create actions:
/t/967/1

Perhaps this initial help plus the advice on the "format value" action may save you from merging the already filles COMMENT_ADD fields with COMMENT manually.

oups :flushed:
how can I delete some Metadatas?
I made some test with new values with the "Comment_Add" and when I go to "view/extented tags", I found some metadatas that I don't want
I've search for a file where the metadatas would be listed but no...

Ok, in the "edit tags info", it works
thank you :rolleyes:

rhaaa sorry, I must be dumb :frowning: but I can't merge the "Comment" & "Comment_Add"
on the soft, in the "comments" column, it's fine, no pb
but when I look at the "info" in Winamp, only that I wrote in the "comment" field is visible
:angry:

Select the files that you want to edit.
Press Alt-T to open the extended tags dialogue.
Select the first field that you want to delete.
Press the red-x-button.
If there are more fields to delete, select then one after the other and press the red-x-button.
Press OK to apply the changes.

This modification deletes all selected fields and their contents.
A similar function (not action) is available in the tag panel for the more frequently used fields. See the field's drop-down list for the corresponding function.

I swear : I done it ! and some values don't wanted to delete themselves !!
maybe because I reload the soft?
anyway : it works :slight_smile:

If you modify the files via the tag panel you have to explicitly either press Ctrl-S or the dis symbol in the toolbar to apply the changes (maybe you have left out that last step).
Closing the extended tags dialogue with OK applies the changes, no extra saving is required.

ok
I can (almost) do what I want
I can't merge the "COMMENT_ADD" and "Comment" (as I said, it seems ok in the column "comments" but the words aren't saved in the MP3 file)
but I can write the infos with the method that you gave me ("View/Extended tags" + CTRL-Return)

thank you :music:

The method to use a column definition as action substitute is possible but not advisable.
If you want to save the contents of two fields in one field, you have to enter the source field (hier: COMMENT_ADD) first and then invoke some kind of modification to the target field (here: COMMENT) to save the changes. This happens every time you modify the target field.

So, a safer way would be to use the extended tags dialogue for first time modifications.
Or, if you have several files with filled %COMMENT _ADD% fields, use the "Format value" action for COMMENT
Use as format string: %comment% %COMMENT _ADD%

that's what I've done (I'va made some websites in Javascript, PHP, etc :wink: so I thought it was something like that) but the result ... :frowning:
maybe it was placed in e wrong place?
I wrote this in the "value" field in the "ajust visibility of the colums" window