some export questions


#1

Hello, this is my first post.
I did dig thru the forums a little but I din't find what i needed yet so I am going to ask this b4 going to sleep in hopes that I will have an answer when i return from work tommorrow.

On this page /t/1495/1 you can download different export templates. I found one that I like but it doesnt seem to work correctly.

I think my problems are 2 fold;
A. What am I to do with this file? I couldn't find instructions on how to use these files yet.

Since I couldn't find anything on how to use them I dumped the file into my export folder where all the other .mte files are but the program doesn't seem to see it. In a second attempt I opened up the .mte file in notepad and selected all(ctrl-A) and copied it. Than I went to tools/options/export create new and deleted what was there and pasted from the other file.

B. When using the regular export templates all of my songs are exported, but when using the downloaded one(html_nickless_javasort_lite) nothing is actually exported. During the export it reads all the files but when looking at the page produced I have no songs yet at the top of the page it tells me that the total size and duration and whatnot. For testing purposes I selected a handful of songs and exported again and that worked. This leaves me to believe that I must have "installed" the dled .mte file correctly but there is a cap on the amount of songs it can output?

If there is a cap is there a way to remove it? Did I just install the template wrong?
Please help!

And if anyone hasn't seen the preview for that template it is really nice :slight_smile:


#2

From the start menu choose run, write %appdata%\MP3Tag for the command to run and press enter. This brings you to the correct place where to copy the .mte files.

When you restart MP3tag you'll find the export cofiguration files you have added.


#3

Hi dashaus!
It works fine for me exporting about 5000 songs :unsure:
Could you open the erroneously exported file with a notepad and look if it's so empty like it looks like? My config uses JavaScript, so it's possible that it is displayed wrong if you have some strange characters in tags I've not thought about or it can be blocked by your browser. Btw, which are you using?

Regards
nickless


#4

Great that worked flawless!

Hmm and her eim only trying to get 3834 songs to export!!!
Opening the htm file in notepad yields what appears to be the links i need to be seen ie:
"a[14] = new Array(18);
a[14][0]="Strung Out";
a[14][1]="";
a[14][2]="00";
a[14][3]="American Lie";
a[14][4]=154;
a[14][5]="";
a[14][6]="Punk";
a[14][7]=128;
a[14][8]=" kbps";
a[14][9]="MPEG 1 Layer III";

a[15] = new Array(18);
a[15][0]="Strung Out";
a[15][1]="";
a[15][2]="00";
a[15][3]="Betrayal";
a[15][4]=153;
a[15][5]="";
a[15][6]="";
a[15][7]=128;
a[15][8]=" kbps";
a[15][9]="MPEG 1 Layer III";

a[16] = new Array(18);
a[16][0]="Strung Out";
a[16][1]="";
a[16][2]="00";
a[16][3]="Bring Out Your Dead";
a[16][4]=171;
a[16][5]="";
a[16][6]="Blues";
a[16][7]=128;
a[16][8]=" kbps";
a[16][9]="MPEG 1 Layer III";

a[17] = new Array(18);
a[17][0]="Stopwatch";
a[17][1]="Forget Me If You Can!";
a[17][2]="04";
a[17][3]="Did We Miss It?";
a[17][4]=197;
a[17][5]="2001";
a[17][6]="";
a[17][7]=96;
a[17][8]=" kbps";
a[17][9]="MPEG 1 Layer III";

a[18] = new Array(18);
a[18][0]="Strung Out";
a[18][1]="Various";
a[18][2]="00";
a[18][3]="Every Breath You Take";
a[18][4]=190;
a[18][5]="";
a[18][6]="Punk";
a[18][7]=128;
a[18][8]=" kbps";
a[18][9]="MPEG 1 Layer III";

a[19] = new Array(18);
a[19][0]="Stopwatch";
a[19][1]="43 W-A Bullet";
a[19][2]="03";
a[19][3]="Forget Me If You Can";
a[19][4]=184;
a[19][5]="";
a[19][6]="";
a[19][7]=96;
a[19][8]=" kbps";
a[19][9]="MPEG 1 Layer III";

a[20] = new Array(18);
a[20][0]="Strung Out";
a[20][1]="Crossroads And Illusions";
a[20][2]="00";
a[20][3]="Ghost Town";
a[20][4]=127;
a[20][5]="1998";
a[20][6]="";
a[20][7]=128;
a[20][8]=" kbps";
a[20][9]="MPEG 1 Layer III";
"
Uhm as far as strange characters i may have some - "¿" <- thats the only one i can think of that MIGHT be in there( ok I went thru and find and replaced all upside down question marks and still no dice)

And the browser is ie6 ..i know java works on it bc liek i said exporting a small amount of songs works :frowning: -----------------

ok i just installed firefox to test it and i have some java errors maybe u can help me with :slight_smile: ok most of them say "write_dots is not defined" 1 says "read_settings is not defined" and one says "unterminated string literal" and they all point to my music.htm file at different lines (this info is form the javascript console in firefox)


#5

Hm, this part seems to be ok.

Thats more interesting, would you please post everything about errors from javascript console?
I think that the "unterminated string literal" could cause all of this errors (and this can happen if there is some strange character (I mean "null", CR or something like this I've not filtered out)).

Regards
nickless

P.S. If there is something like this:
unterminated string literal: a[0][9]="MPEG 1 La
then please post a part of export file around this line.


#6

will do as soon as i get home form work :slight_smile: (6ish est)


#7

Ok following is each of the different errors. I have a few write_dot errors but i just picked one since im sure the fix would be the same for each? Next to the errors is what firefox highlights as the problem in the html. Hoep some of this helps as I am clueless!

edit: for ease of reading now the highlighted html is under the problem

Error: unterminated string literal
Source File: file:///C:/Documents%20and%20Settings/Administrator/Desktop/Music.htm
Line: 3432, Column: 10
Source Code:
a[275][5]="1998

Error: read_settings is not defined
Source File: file:///C:/Documents%20and%20Settings/Administrator/Desktop/Music.htm
Line: 46292

Export file creation date:

Error: write_dots is not defined
Source File: file:///C:/Documents%20and%20Settings/Administrator/Desktop/Music.htm
Line: 46304

8 days, 06:43:06

Error: fmtTime is not defined
Source File: file:///C:/Documents%20and%20Settings/Administrator/Desktop/Music.htm
Line: 46325

kbps

Error: table_length is not defined
Source File: file:///C:/Documents%20and%20Settings/Administrator/Desktop/Music.htm
Line: 46364
if (ie5 || (i%20==19)) { //I don't want make IE worse that it is, but my IE6SP2 is really faster by writing each line than each 20th !!!

Error: avg_btr_second is not defined
Source File: file:///C:/Documents%20and%20Settings/Administrator/Desktop/Music.htm
Line: 46335


#8

I dont know what i did but it now works ::scrathes head:: uh yeah..lol


#9

I would say, one of your files (#275 in this case) had (or maybe still have) an Linebreak-Character (or something like that) in the year-tag (it should be a[275[5]="1998";]).
Maybe you hadn't selected this file when you've exported the last time or you ve just resaved/formatted the tags so this character was deleted.
If you'll see such an error in the future, open the file with notepad, find this place ("a[275][5]=...") and look what file it was, than try to resave or clean up its tag.

Regards
nickless


#10

Thank-you nickless :slight_smile: