Some multivalue tags not displaying in controller

Setup is minimserver on Linux, Hi-Fi Cast on Android, Chromecast Audio for DAC. Performer(s) on each track are stored as one or more ARTIST tags. Everything has been working beautifully for more than a year. All the performers showed up in the ALL ARTISTS list in Hi-Fi Cast, could be searched for, etc.

Recently I installed MP3Tag 3.0 on a new Windows 10 laptop. Since then I've added a few more tracks to the library and improved the tagging of library, cleaned up many tags, added band members as ARTIST tags and so on.

But I've noticed that where a track is recently added or edited, only the first ARTIST appears in HiFi Cast (in the ALL ARTISTS lists, in Song Details, or can be searched for). Undisturbed tracks appear as they always did. Everything appears as normal in MP3Tag.

I'd be very grateful for troubleshooting suggestions. I can't believe it's a bug in MP3Tag, maybe I'm missing something in the options...


It would be easiest if you showed us the extended tags dialogue of a file that works and one that does not.

Thanks for getting back to me. Here's one where all artists list properly:

While with this one only the first artist shows up in Hi-Fi Cast:

I see that the ID3 version information at top left is different: if you can point me to information on sorting that out I should be OK.

Thanks again,

See Tools>Options>Tags>Mpeg where you can set the (future) tag version.
You can filter for such files with
%_tag% HAS 2.3
Select them and press Ctrl-S to save the modification.
Press F3 twice to refresh the filter and see if any files are left (it shouldn't)

Thank you! I tried it on one album and it worked; currently scanning the relevant part of the library to deal with the rest.

One of the differences is the additional ID3V1-Tag in the files not working as intended anymore.
Maybe the software takes only the ID3V1-information if present.
Test if deleting the ID3V1-Tag helps.

Thank you. I'm doing that already.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.