Sources and Actions missing

Im running Mp3tag v2.49 Portable. Been using the portable version for years, and this way i cary my settings (actions and sources) along with me on any computer. But recently i downloaded some sources from this website, and i pasted them in the sources folder as per the instructions, i have installed sources before. But now when i start my software, in the sources button, theres only "freedb" when i click it and search via TITLE and ARTIST, i get this

"---------------------------
Mp3tag v2.49

File "H:\Softwares\Portable Softwares\Mp3tagPortable\App\Mp3tag\data\freedb.src"
cannot be opened.

OK

"

I've got many sources, i cant find any of them in the software GUI.

secondly, when i click on the actions, therres no actions visible ( i had saved many)..but now i get a blank window. But if i click the tiny arrow near the actions button, then i get this error

"


Mp3tag v2.49

Runtime Error

File: .\mtmainframe.cpp
Line: 4532
Term: _S_TRUE(bRetVal)
Code: 00000000

The application encountered an unexpected exception
and is in
an undefined state. Please close the application and
send the
file

H:\Softwares\Portable Softwares\Mp3tagPortable\App\Mp3tag\Mp3tagError.log

and a detailed error description to our support staff.

email: support@mp3tag.de

OK

"

Also is there anyway to get the tags of multiple mp3's at the same time?.. such as album, albumArt and year?..

Mp3tagError.log (1.38 KB)

Does this path exist?
Have you checked owner and access rights for that path?
Best would be if th owner of the path is also the user-id that executes mp3tag.

that folder exists, but that "freedb.src" file isn't there.. i copied it from the settings directory, and pasted them in that folder, still no luck. The only thing in that folder is the "columns" stuff . And the file i have attached earlier is from the application data folder in my user documents. But the error.log isn't anywhere to be found in the portable application directory.

Assistance needed, as i feel like a fish out of water without organizing my pending music. :slight_smile: thank you..

check if you are any luckier if you copy those required files into a structure in
%appdata%\mp3tag
(which would then mean that it is not a portable application)
Have you checked the ownership and access rights?

still nothing.. yeah it has full rights.. no restrictions


ok, i've solved my problem.. thanks alot.. i just installed the full version, to check if it works, and it loaded up all the custom settings on first try, maybe coz the portable one had saved some %appdata% in the C: drive, so i copied the actions and sources there.

I can't do without my portable version though, so i installed another portable version somewhere else, copied the data to my existing portable folder, and then ran it, this time it ran with no errors.. Looked hopeful, so next step was to copy all the sources and actions etc. even they were in the right folder, they wouldn't show up. So it seemed like mp3tag was loading them from another folder, within in the portable application, i found another default data file, and another one in mp3tag folder, not the settings folder, so i dumped all the actions etc, so then fired it up and it loaded up all the settings and sources/actions were there....

So special thanks goes out to you ohrenkino