Special Characters added to title

I'm new at this utility but I like MP3Tag for it's functionality. I used it to mass-convert some genre's to make them consistent. In the process, it added some special characters (ÿ) to the title, album and genre of each track I converted. I used the convert utility to remove them so they do not show up now in MP3Tag but they still show up in my MP3 software (Rio) and in Nero. Can you point me to a solution to remove them?


Look at the this pinned topic:


If your applications and / or hardware player does not support unicode properly,
use v2.3 ISO 8859-1 tags only.

@dano: d'oh, look at the posting time of the replies :wink:

Thanks Dano and Klaasklever. I suppose this comes up a lot but without knowing which post / tag format issue related to my problem, you saved me some time in getting to an answer. A few things surprised me in this problem. One was that MP3Tag also displayed the special characters. The other is that Nero doesn't support the standard Unicode tags (I'm running 6.3 so maybe 7.0 does). Either way, I had to run a convert to remove the characters that were there and once I had changed that option, it stored them without.

I can no longer see the special character in most of the apps except for Nero where they can be seen and when I burn an MP3 CD, they show up in the titles, album and artist fields of my players. I've tried creating a conversion and I have tried saving them now that I am using the 8859-1 tags option but I can't seem to get rid of them. Any other suggestions?

By the way, the special characters are displayed in foobar2000. I can edit them out manually but am looking for an automated script.

You can use the Actions to replace the special characters.

Dano - that's what I meant by trying a conversion. Initially, the special character (ÿ) was displayed in MP3Tag but I created an action to replace it with "" and it was no longer displayed in the tag. However, even though it is not displayed, it is still in the tag as is shows up in at the beginning of the title, artist and album in both Nero and in foobar2000. I don't know how to create an action that will find a and eliminate a non-displayed character. I looked in foobar2000 as well and did not find anything.

I now have an answer, in case this helps anyone else in this situation. I could not get an action to find and remove the character that was in the tag data, as it was not displayed in MP3TAG. However, when I changed the tag optiont to write only UD3V1 tags, all those characters were removed which I verfied in foobar2000. I then switched the option back to UD3V2 / ISO-8859-1 and saved them again and they look fine. Knowing why this happened is beyond my current knowledge but I now have tags that show up properly.

I had a very similar problem appear after upgrading from v2.35 to v2.36. It turns out that this is due to the default ID3v2 character coding changing from UTF-16 to UTF-8. I think this is a bug: /t/3397/1

There are some similarities and a few differences as well. I was using 2.35 during the entire process. My special charachter (ÿ) was not the box and showed up at the beginning of artist, title, album vs at the end. I'm not using Itunes but the character did not show up in MP3Tag, only in Nero and in Foobar2000. I'm surprised so few have encountered this.

I'm having this problem as well. Hopefully if I change the write to ISO 8859-1 it will work, as I think someone posted that as a fix on here.

Yep, it should. Just press on the :mt_save: icon and Mp3tag should change the encoding.

Maybe your experience will be different but once the characters were embedded in the tag, just changing to UD3V2 / ISO-8859-1 did not remove them. I had to switch to UD3V1 to remove them .

I thought the added characters are only a display issue in iTunes and similar programs, while Mp3tag still displays the correct information. Now I saw that you said that Mp3tag also displays wrong titles, etc.