Staging sparse package failed : Win11 no context menu

I've made a fresh install of Win11 22H2 and when I try to install mp3tag v318b 64bits I have the same error message than here :

I've downloaded the latest night build, but no luck.

I tried to to install the 3.16 which seemed to work for some users, but no luck.

The context menu is absent from the old context and the new context as well.

After registering the Mp3tagshell.dll with regsvr32, it came back on the old context menu, but not on the new one.

Do you have any suggestions?

Thanks and regards,

Version mp3tagv318-x64 installs fine on Windows 11 Dev build 25247

Have you followed the extra notes when installing the 64 bit version?

I also tried to install the 3.16 32bits, but same error message during the installation.

And you un-installed the previous version before you installed the new one?
(This is only ncessary if you go from 32 to 64 bits or the other way round).

So: if you had the 32-bit version,
un-install that,
then install the 64-bit version.
If you had not done that,
un-install the 64-bit version,
install the 32-bit version,
un-install the 32-bit version to get rid of all traces in the 32-bit world,
finally install the 64-bit version and also restore the backup-ed configuration.

Yes, I cleaned up the registry as well.
The error message appeared during the very first installation of mp3tag, and everytime I install it, whatever the version or 32/64 version it is.