Strange behavior with removed tags

Hi to all. I have a very strange problem. I have used mp3tag 2.48 to fix the tags for 5000 songs. The program is very nice and helpful. My problem is that when i play some of that songs with the very nice audio player Jaangle, i can see some comments in the tags that i erase with mp3tag. I open this files with the popular tag editor Tagscanner and i can see more erased comments. Maybe i did something wrong. Can anyone help? Thanks.

Sorry for my English.

As it is rather difficult to find the solution straight away, I start with something very basic:
After you selected for a comment, did you press the "save" button?
Changes that you enter in the tag panel have to be saved. This differs from the handling in the file list, where a modification is written straight away.
Another possibility is that you do not read the same tags that you write.
Check this in Extras>Options>Mpeg.

Sometimes you can have the same comment in both the ID3v2.3 tag and the ID3v1 tag.

When you used Mp3tag to erase the comment you might have only erased the ID3v2.3 tag and not the ID3v1 tag. Jaangle and Tagscanner might be showing the ID3v1 tag.

To see the ID3v1 tag in Mp3tag look at the Mpeg Read options and make sure ID3v1 is the only box checked and refresh the view. To delete the ID3v1 comment tag make sure ID3v1 is checked under the Write option.

Thanks for replying. Can anyone tell me how to delete completely the ID3v1 tags? Thanks.

Set the settings as stanman said.
Then select all the files that have the duplicate comments, right-click in the files list and select the "Cut tags" function from the context menu.
Immediately afterwards right-click again but this time select the function "paste tags".

All files that you edit in the future should re-write the tags automatically.

Thanks for replying but can you be more specific? I didn't understand how to do it. Thanks.

Open MP3rtag.
Open Extras>Options
In the tree select "MPEG"
For "Read" tick MP3 V1 & V2. Do not tick APE
For Write tick "V2" only
For Delete tick V1, V2 and APE.
Close the dialogue with OK.
Now: read in the files that you want to edit.
e.g. you could also apply a filter to show only the files with a comment:
Press F3 to show the entry field for Filter.
Enter
NOT %comment IS ""
(please not the words in capitasl)
Select all these files in the List (Ctrl-A)
Right-click on the list, select the function "Cut tags"
Let MP3tag remove the tags. THis may take a while.
Once MP3tag has finished, right-click again to open the context menu, only this time select the function "Paste tags".
Let MP3taqg paste the tags. THis may take a while.

Afterwards your tags should be of one version.

Open the dialog "Mp3tag/Tools/Options/Mpeg" and write down the current settings.

Set the "Mp3tag/Tools/Options/Mpeg" options to ...

  • Read
    • [_] APE
    • [_] ID3v1
    • [_] ID3v2
  • Write
    • [_] APEv2
    • [_] ID3v1
    • [_] ID3v2
      • (_) ID3v2.4 UTF-8
      • (_) ID3v2.3 UTF-16
      • (_) ID3v2.3 ISO-8859-1
      • [_] ID3v2 only if ID3v1 too small
  • Remove
    • [_] APE
    • [x] ID3v1
    • [_] ID3v2
3. Select all the files, from which the ID3v1 tag should be removed.

Execute the menu option "Mp3tag/File/Remove Tag".

Set the "Mp3tag/Tools/Options/Mpeg" options back to the previous setting.

  • Read
    • [_] APE
    • [x] ID3v1
    • [x] ID3v2
  • Write
    • [_] APEv2
    • [_] ID3v1
    • [x] ID3v2
      • (_) ID3v2.4 UTF-8
      • (x) ID3v2.3 UTF-16
      • (_) ID3v2.3 ISO-8859-1
      • [_] ID3v2 only if ID3v1 too small
  • Remove
    • [_] APE
    • [_] ID3v1
    • [x] ID3v2
6. Refresh file view.

DD.20110418.1140.CEST

Why do you disable the Read & Write options Detlev?

Well, to be sure, all Read and Write options can be left unchanged or set to "on" to verify the correct selection of files before removing the ID3v1 tag.
Just only for the removal of a complete tag structure, the Read and Write options are not involved and not necessary.

DD.20110418.1224.CEST

Thanks. It's working.