Tag not actually saving, despite being changed in mp3tag

Recently just changed an artist name in mp3tag and saved it. The artist had an apostrophe in it, but it was tagged with the weird one, instead of > ' <. I replaced it with the correct apostrophe and saved it, closed mp3tag and opened the album on Musicbee and there was no change. I reopened the album in mp3tag and it shows as changed, even though it's not being displayed as changed in Musicbee. I then had to change it through Musicbee and that worked. Any idea what could be happening?

Edit: No tags are actually being changed, despite appearing changed in mp3tag.

Edit 2: I think it might just be Musicbee somehow not knowing tags have been changed.

Doesn't Musicbee have a database in the background to store file data?
This would have to be updated.
What happens if you rename the file (slightly) and add it to Musicbee - does this (new) file show the changes?

2 Likes

Haha, before reading this I decided to rename the files (the file names) and it fixed it! Thanks!

While I was visiting the forum I saw 2 posts that helped me change 2 things that annoyed me (Double clicking a song opening the file, and having to confirm every change). All in all I'm happy now!

1 Like