Tagging m4A files

If I open the folder and high light the m4a files and select MP3Tag from the right click context menu I can see the files in MP3Tag but if I right click on the folder I can't. Do I need to change something?

You probaby have not defined "*.m4a" in
Tools => Options => Tagy => Restric incoming files to.

This sounds like as the standard "Mp3tag Shell" does not support folders, maybe it will be implemented later.
In the meantime you may register your own commands.

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\Drive\shell\Open with Mp3tag]
@="Open with &Mp3tag"
[HKEY_CLASSES_ROOT\Drive\shell\Open with Mp3tag\command]
@="\"C:\\\\here\\\\full\\\\path\\\\to\\\\Mp3tag.exe\" /fp:\"%L\""
[HKEY_CLASSES_ROOT\Directory\shell\Open with Mp3tag]
@="Open with &Mp3tag"
[HKEY_CLASSES_ROOT\Directory\shell\Open with Mp3tag\command]
@="\"C:\\\\here\\\\full\\\\path\\\\to\\\\Mp3tag.exe\" /fp:\"%L\""
[HKEY_CLASSES_ROOT\Folder\shell\Open with Mp3tag]
@="Open with &Mp3tag"
[HKEY_CLASSES_ROOT\Folder\shell\Open with Mp3tag\command]
@="\"C:\\\\here\\\\full\\\\path\\\\to\\\\Mp3tag.exe\" /fp:\"%L\""

Copy the above code block into an empty text file, ...
edit the path entries, ...
save this text file as "OpenWithMp3tag.reg", ...
import the reg file into the Windows registry.
Try it out in Windows Explorer.

DD.20160419.1144.CEST

Folders are supported.

Hmm, may be a question of access rights?

DD.20160419.1217.CEST

As I wrote above this happens if you have not defined a media-suffix to be read.
If you select files in the context menue they are read, regardless of the definition.
If you select folders, only defined suffixes are read.

Yes, indeed, you are right!

DD.20160419.1538.CEST

That was it! I figured it had to do with file association but I didn't think of it from the other side.

Thanks