Tagging m4b files

Hi, new to mp3tag and feel I must be doing something wrong regarding tagging m4b files.

It may be related to my playing software rather than mp3tag but I'm trying to narrow down the issue. Heres my problem. Hope you can help.

I've tagged all my audio files. MP3s and m4bs are all scanned into Kodi. Artists and Albums etc all populate as expected. Genre however does not. If I look in the m4b album information in kodi I see no mention of genre unlike mp3s.

I'm wondering if I'm missing something in the tagging process in mp3tag.

I've tried changing the mapping tagtype:MP4 Source:©gen | gnre Target:GENRE

Saying his, Plex does recognise the tag if i input them normally without any problem.

Does anyone have any experience of this issue?

You cannot map the internal tag field identifiers to anything else.
Either such a field is supported by MP3tag or it is treated like a user-defined field.
The field GENRE is already supported and uses the named atoms.

What do you get if you remove the mapping?

Ok, i dont really understand mapping anyway.

So without any mapping etc that I did to begin with. I just dragged my m4bs into mp3tag, changed genre and some other details and saved.

Kodi does not appear to see the tags in the m4b, plex does see them. So I'm assuming this is a kodi issue not reading m4b tags.

In preferences i have everything ticked. I did see on here an old post saying possibly change these when tagging m4b?

all i can see is kodi reads \251gen tag for mp4 realting to genre. But i have no idea of what to do with this information

That is more or less that what MP3tag writes - as you can see in the linked documentation on mapping.

Check the extended tags dialogue whether you have other fields that may show the genre data.
Please note that the different ID3 versions apply to MP3 files.

Well its very strange on the file im testing on:
If I use Yate to view tags, i see genre as 'Folk' same as music brainz
Foobar i see audiobook / fantasy / series (shows chapters)
and mp3tag says 'series'.

Seems different tagging or playing software is seeing different things

There should be a setting that also lets you see chapters in MP3tag. See Options Ctrl+O >Tags>Enhanced

im on a mac, that doesnt appear to exist.

Please have a look at the documentation:

and see what other options can be set.

nothing im afraid. Ho hum. Dont think I'll ever get to the bottom of it. Must be kodi