Tags appearing that I can't see


#1

Bit of a strange situation.

I have cleaned up my library and removed all tags that I don’t use and left all my mp3s with only ID3v2.3 tags.

However, when my squeezebox server does a full clear and rescan there are 46 mp3s (out of about 40,000+) that still seem to have rogue tags in the fields

Replay_gain
Replay_peak

I can’t see either of these tags on the files using mp3tag. Removing tags and resaving still doesn’t shift them either!

I’ve even tried deleting the tags from the squeezebox database in case they are some residual thing that doesn’t get cleared when I do a full rescan, but they just come back again, so the MUST be present somehow on the mp3 file.

Any ideas?

Also for some reason (this may or may not be related) – after the scan Squeezebox reports certain files have the compilation tag set to 0 and others have NO compilation tag (null)

Again – I can’t see ANY mp3s with a compilation tag set using mp3tag so I don’t know where that comes from. This one is not so important as compilation=0 is the same as no compilation tag anyway


#2

Check if these files have APE tags - either open extended Tags dialogue for each individual one or set a filter:
%_tag% HAS APE

If so, delete these tag versions
Also, there seems to be a problem with files that have the compilation tag set to zero. Either it is there with the value 1 or be deleted altogether.


#3

Nope - that's not it. I deleted all the APE tags, and mp3tag is set to read them if they exist (which they don't!)


#4

Pity.
Actually, if MP3tag is set to read them, they overwrite any MP3 tags ... so it might be even better not to read APEs.

So, if the tags do not show up in MP3tag, then it is probably the local library of your squeezebox that is a little stubborn. Delete the entries from the squeezebox library and re-read the files.


#5

yep, do a "clear and rescan" music scan. And you don't see those replaygain tags in mp3tag when you right click on a file and choose extended tags??? I see those on both my mp3 files and FLAC files.


#6

I don’t see these replay_gain tags in mp3tag when I right-click and choose extended tags.

I clear out the squeezebox database and rescan and they re-appear in the database. They MUST be in the mp3 file somewhere but mp3tag is not seeing them


#7

OK – this is driving me mad now!

Replay_gain and replay_peak tags are not present in ID3 or APE tags. I’ve checked this in mp3tag, winamp and audacity – there is nothing there! I’ve also checked the mp3 in a Hex Editor to see if the string appears...nothing

Manually deleted my squeezebox database and did a full rescan and index – and these tags STILL appear in the database! Agh!

Are there some other (non ID3/APE) tag types that might be hidden away somewhere that Squeezebox is picking up?


#8

hmmm. very challenging. I know that Squeezebox does NOT add or write tags unless you've got additional plugins that might do this (like trackstat, although even that I believe writes its own database file and doesn't touch the tags).

I assume you are NOT using itunes integration (i.e., SB is not picking up anything from your itunes database, which although it doesn't use RG values, it does use Soundcheck values that are similar).


#9

Not using iTunes no - but it's entirely possible that these handful of offending mp3's have come from iTunes as - shall we say I "borrowed" them from a friend!

My son has iTunes on his laptop so I can have a look at them there


#10

Within mp3tag Look at ITUNNORM or COMMENT ITUNNORM or something like that. This holds the sounndcheck value which I think SB will use just like RG values. Should look like a string of letters/numbers.