Tags are not saving changes


#1

Almost all of my tag changes are not saving on my MP3s. The only change that works is the filename - everything else (artist, title, album, and track) does not get saved. When I click the save button, no errors occur. I checked Tools > Options > Tags > MPEG and this is what I have configured:
Read - ID3v1, ID3v2, and APE
Write - ID3v1, ID3v2, (ID3v2,3 UTF-16)
Remove - ID3v1, ID3v2, and APE

I checked my file attributes for my MP3s - they are not set to read only.

I have also tried running ID3Kill - what that does is remove any info present in any other column on the MP3 but leaves the filename. When I try re-saving, it reverts back to the original info that I'm trying to edit (still keeping the filename, which again, is the only thing that the editor is allowing me to save).

Last thing I tried was copying the directory with my MP3s onto an external drive, ensuring that read only was disabled, but no luck.

I haven't used this editor since 2008, and I don't ever recall having this issue. I'm running Win 7 and have MP3Tag 2.89a installed. Any assistance would be appreciated.


#2

As you read APE tags but you do not write them, they stay as empty as they are.
And as APE has priority over ID3 tags (in MP3tag), you see the "emptiness" of the APE tags.

Switch off to read APE tags and everything should be fine.


#3

I never had a situation that empty (=not existent) ape tags covered up ID3V2-tags.


#4

Hello and thanks for the quick response - I've switched APE off in read, but it still won't save my changes.

Also, I have tested with other MP3s and I'm getting the same results.


#5

As MP3tag's primary purpose is to edit tags, it usually can do it.
If your problems were a universal problem, the forum would be full of such descriptions. At least I don't have these problems.
And as I cannot look over your shoulder, you have to help a little.
So, how do you save tags?
Do you get any error messages?
Does this happen to old files as well if you try to edit them again?
Are the files ok in respect to integrity? (Have you really checked with one of the common utilities like mp3diags, foobar2000, mp3val
A screendump of the extended tags dialogue from one of the files might help.


#6

I figured it out, the files that won't edit are corrupted. I haven't sat down and listened to them yet, but when I played back one of them, it was garbled and incomplete. Another one showed an "invalid codec" error when trying to play back. I feel so stupid... sorry to waste your time.:frowning: