Tags do not alway write

I have been noticing that some mp4 files are not getting the tags written. I am using the file name to tag icon usually in a 5-10 file long list. Most will tag, but some will not. I have seen it happening for the last 6 months and keep updating to the newest version thinking it might get fixed. I have tried the non tagged files one at a time and no difference. But If I open File Explorer (Win 10) and grab the file name then open the file properties, go to the Details Tab I am able to write them successfully into the Title Field.

I tried an experiment, added a bogus tag via the properties method, then went back into MP3TAG and tried to write it again from File-> Tag. No joy, but it did blank out the bogus tag, which was unexpected.

Whats up with that? Thanks, Bill C.

In the old days MP3tag did not support MP4 files with Nero chapters.
V2.85 should support them as this was a newly added feature.
So please check if you use that version (your signature shows V2.70 at the moment).

Apart from that it could always be that the files got corrupted somehow.

I have been using it for a few years on mp4 files, and just noticed I was using 2.82. I upgraded and two things occurred. It did fix the tag issue! sort of oddly, there were two files in the directory, but it showed each one 4 times. I only highlighted the two missing the title tag. And it showed they were fixed, but file manager didn't even after a refresh. Then I went back into the app and highlighted all 8 files, and now its actually written the title in the two files. I cannot explain it thinking it saw each file 4 times. They all showed the same path, not like they were in a subdir... really odd.

But it did add a lot of .mkv files to the field, It never showed them prior. Now I need to figure out how to filter the .mkv files from the list. :slight_smile:

I need to find out where it added the new functionality of showing mkv files..

Go to
Tools -> Options -> Tags -> Restrict incoming files to
if you do not want to handle MKV-files at all.

I you only want to filter them now and then use the filter (F3):
Filter expression: NOT %_extension% HAS mkv

Thanks for that info.

I Just re-posted an edited version of this post in the Bug forum.

I am seeing something very odd since upgrading to 2.85. If the file shows MP4 Nero under the TAG column I see 11 files listed instead of the 1 file that is actually in the folder.

If I highlight all of them, i seem to get the file tagged correctly which is good, but there must be a bug here.

I have attached a screen shot... remember there is only one file in the folder that begins with Dirk, and nothing in sub-directories as you can see in the path column.

I am guessing the Nero verbiage has no bearing on this, see the second screen shot. 11 lines, but just 1 file, no Nero in the tag field.



Hello
I'm using windows 10 for few days now (come from win 7), and I noticed that in windows explorer tags of my songs are not being displayed even if I'm sure they are saved in the files because I edited them with mp3tag and in windows 7 they had always been displayed in windows explorer.

What kind of files are we talking about? (This thread is about MP4 files).
If you have MP3 files, check if you have V2.4 tags in the files.
For some time, Windows did not show these. You have to use ID3V2.3 tags to be sure.
Check the already written files and also check the settings for writing in Tools>Options>Tags>Mpeg.

Also, in Win 10 the columns might need to be added for your tags to show. Music tags show by default but video does not.

-Bill