Tags not being recognised


#1

Just changed my phone from Windows 7 to Windows 8.

Windows 7 used Zune to transfer and sync music, Windows 8 has an option of a Windows transfer Programme which is beta version or just drag and drop using Windows.

I have used MP3TAG to tag my music, but for some reason on some compilation albums which are tagged as various artists as the artist and album artist, and with the correct album, the Windows player on the phone is picking up tags associating tracks with different albums.

Do not know where the palyer is picking up this information from.

Any clues?


#2

You could check in MP3tag what kind of tag versions the files with awkward behaviour have.
Set the filter to
%_tag% HAS APE
and see if this leads to any hits.
If so, delete the APE tags and try your phone again.

If this does not work, check the files that behave properly if they have a field
COMPILATION set to 1.
(and if the strange ones don't then add this field with the contents 1 and see if that does the trick).


#3

how do i do both of the above, do not know how to filter.
Right clicking on the columns brings up a customise column tag but there is np compilation field to set?


#4

The filter is explained in the online help.
Press F3 to show/hide the filter input box at the bottom of the main window.
There enter the string I mentioned.


#5

found how to add compilation column, this appears to have fixed it by setting all tracks to 1


#6

no, not fixed, even though compilation set to 1, it still is picking up rogue info from somewhere and is applying that information


#7

Now then, what did the filter show?


#8

filter showed no results


#9

Pity. Would have made life so much easier.
On the other hand: good, no APE tags which might block the view.

Is there a way to make the files read-only (haven't got a phone like that)?
There certainly is for windows - but is this tranferred to the phone as well?

anyway:
open a cmd-shell (Press windows-key+r and type in "cmd")
navigate to the music folder on your hdd.
There, enter the following command:

attrib +r *.mp3 /s

This sets all mp3 files to read-only in all subfolders.
To make them read/writable 8again) type in:
attrib -r *.mp3 /s

Copy the read-only files to the phone and see what it does.


#10

how do i navigate with the cmd window open?


#11

enter the drive letter of the drive on which the musik is followed by a colon, e.g.
d:
press enter
enter the command "cd " followed by the name of the directory which leads to the music e.g.
cd music
press enter
repeat that cd command and the appropriate name until you have reached the top most folder for the files that should become read-only (you might want to try with a smaller portion first).
Now enter the
attrib +r *.mp3 /s
and press enter.
Wait until the command has processed the files - depending on the number this may take a while.
You may leave the command shell open while you try the files on the phone.


#12

no, still the same problem


#13

I am running out of ideas.

just to make sure: mp3tag shows the correct entries, right?
Also, WMP (on ordinary windows) has the option in Extras>Options to gather further information from the web - this should be switched off.
And if you can and have such a function on the phone: use a firewall to block WMP access to the web.


#14

ok, have turned off X Box Music which it says "makes your music experience great by updating song information, downloading artist and song information etc etc" that seems to have fixed it.

Thank you for all your help...