Tags show in Mp3Tag but not in Windows Explorer

I've just downloaded (my first) from What.CD -- a 1961 classical music disc. First, it took several minutes to load into MP3Tag (normal time is almost instantaneous). Second, tags show in MP3Tag but not in Windows Explorer. Third, the MP3s look OK but won't play in anything. For example, Media Player Classic throws up a diagnostic box stating, "MPC-HC could not render some of the pins in the graph......." I see lots of discussion online about each of these problems. One suggestion is to remove all tags and re-install them. I've tried that several times with no effect. Each time the "Title" shows in MP3Tag but not in Explorer and it won't play.

Has anyone any further ideas to help? Many thanks.

Check in Tools>Options>Tags>Mpeg if you write V2.3 tags and not V2.4
WE does not understand V2.4 tags.

If the tracks do not play, you should also check them with mp3val.

Thanks, but in Tools>Options>Tags>Mpeg in the Write section there are only ID3 options, there's nothing about ID2 of any version. I'm using Mp3tag 2.63
My Write section has ID3v1, APEv2, ID3v2 (followed by various version of this, all ID3v2.x etc)

Yes. and the x should not be 4.

But hang on! the first suggestion to me was use only 2.3, not 2.4, now you're suggesting 3v2.4, is that right?

Perhaps I should spell it all out. I see three sections:

Read: 3v1, APE, 3v2 (all checked)

Write: 3v1 APv2, 3v2 (with four options, all 3v2 xxx) (right now the first and third are checked, with
3v2.4 UTF-8 checked)

Remove: 3v1, APE, 3v2 (right now the first is not checked, the other two are)

With these settings when I click on File>Remove tag nothing happens

No. the x should be 3 (not 4).

Good

Not good. First: OK, Second: OK, Third: should be V2.3

Should be: all checked.

You can see the current tag version in the file list column "Tag". If the odd V2.4 crops up then this explains why WE does not show any tags.

Thanks folks. There are now no 2.4s anywhere but still no "Title" showing in WE. There's something else seriously wrong because (a) the 31 files from this double CD take 2 min to load into Mp3tag whereas most discs take a few seconds, and (:sunglasses: they won't play anyway. I'll pursue mp3val etc.
Thanks again folks, I'll bow out at this point.

Just curious ... what filetype are the files?

DD.20140825.1630.CEST

They are mp3s (Arthur Grumiaux, Bach Sonatas and Partitas). See attached screen grab of what happens when I try to play it, and note the absence of title.


I should have added that Title and all the other tags are there in Mp3tag, but somehow I have the feeling it's not an Mp3tag problem, that's why I was bowing out, at least until I can do some more figuring out, but thanks heaps.