"Text file - Tag" fails to apply to multiple files

When I select multiple files and try to apply the "Text file - Tag" option, it only successfully tags the first file in the selection. It displays an error for the rest of the files in the selection. I have no problem using this feature on each file individually, so its not an audio file or tag configuration file error. I've tried isolating the issue to only mp3 files or wav files, but no matter what, the bug appears on all types of audio files.

Step 1. Import and select multiple audio files from the list. Click convert, and then "Text file - Tag":
image

Step 2. Use a known good tag configuration file and list of format strings, and click OK:

Step 3. The tags are only applied to the first file in the selection. A "No matching entry for file..." error is displayed for each additional file in the selection:

WORK-AROUND
The workaround I have in place is to apply the configuration to each file individually by selecting the first file in the list, and pressing the following: "Alt" key, "C" key, "X" key, "Enter" key, "Enter" key, "Down-arrow" key.

Then I repeat the process starting at the Alt key again. As you can imagine, this is very time consuming, especially when I have sometimes a hundred files or so. Please let me know if you need additional information. Hopefully this is easy to fix.

I just imported data with 3 sets of data into 3 files.
So I suspect that you have data with separators that does not match the list of fields.

Then why does it work for each file individually with no errors? When I use the same configuration file and strings with each file individually, it does not error and it does successfully apply the tags correctly.

I don't know.
I selected the 3 files, had 3 records in the text file, entered the tag fields - and 3 files got processed.

So I would suggest that you look at the data file (again).
Perhaps if you have a text processor then import the data file and transform the data into a table with the same separator that you use for the import in MP3tag (I think it is a semicolon).
See if the columns match.

The fields match up:

I've tried removing the copyright symbol from the comment field, but it made no difference.

I am not quite sure that I understand what you do:
Do you have a data file with as many (or more) records as selected files?
Do you want to copy the same set of data to several files?

In any case it looks as though the number of records in the data file has to be equal or larger than the number of selected files.

oh, that would explain it then. I have a single record in the data file, and I want to apply that record to all selected files.

So if by design the file needs to have an equal or greater number of records, can I just create a data file with 500 of the same records? I'll give that a shot and report back.

Wow, that was it. Thanks a lot for your help ohrenkino!

As you can see the function is not made for this scenario. It would be much easier and faster to select your 500 files in the column-view, see that the needed tag-fields are configured in the tag-panel, and change them manually in the tag-panel in one go for all the selected files.