Textfile - tag "No matching entry for file"

Can anyone spot the cause of this error?

http://i.imgur.com/rXy3VMZ.png

Same with separator TAB replaced by ";":

http://i.imgur.com/u0Gu8Ev.png

There seems to be a mismatch between data format and import format mask.
This works ...
Dataline:
T:\TEST\chrisjj.import\01.abc.wma;10
Formatstring:
%_path%;%rating%

DD.20140901.0909.CEST

Now I see the mismatch is between data and file pathnames. Serves me right for working so late :slight_smile:. And perhaps for using pathnames needlessly absolute rather than relative.

With files corrected, I find data and format string do match: http://i.imgur.com/1v4t1U8.png

Thanks D.

PS I find using TAB as a separator is something else that can lead to user error, since in history it is recognised but hidden:

But alternatives have a much higher chance of appearing in a field value, causing parse errors.

For me and my Mp3tag it is not possible to enter a TAB character into the edit field for the Formatstring in the dialog "Textfile - Tag". How can you achieve this trick?

DD.20140901.2116.CEST

Detlev, I paste it from the clipboard.

And to be super sure, I copied it from the data file :slight_smile:

Subsequently one can alternatively get it from the input history, where though invisible, it is active.

I copied the formatstring text from the Windows Notepad into the Mp3tag edit line, and the formatstring having one TAB character as the separator looks like the following picture shows; it does work successfully in the import process with a text file having the same line format.

DD.20140902.1110.CEST


I am surprised the TAB shows as a hollow box, not a space as here on V2.62. What is your Mp3tag version?

Mp3tag v2.63, Win XP, Font Tahoma.

DD.20140902.1810.CEST

Ah, mine is Win 7. Trying XP now, I get the same as you.

That's rather poor of Windows to change the display, I think.

Maybe there is an option anywhere, not to expand a TAB into white spaces.

DD.20140902.1922.CEST

Regardless. I.e. I think it poor for Windows to change the default display. But now I am forewarned (and probably will never return to XP for audio), I shall leave it as it is. Thanks D.