Titel Nummerierung mit führender 0 - Titel aber schon bearbeitet


#1

Erst mal ein "Hallo" an Alle - das ist mein erster Post hier.
Folgendes Problem:
Ich habe alle meine MP3 Dateien am NAS schon mit MP3 Tag bearbeitet, daß die Tracknummer beim Titel vorangestellt wird.
Nun sehen meine "Titel" folgendermaßen aus - je nachdem wie der Tag "Track" ausgefüllt war - z.B.:
Beispiel 1: 5/13.Bye Bye Bye (10/13.xxx)
Beispiel 2: 1.Best Night (10.xxx)
Beispiel 3: 01/15.The Captain (10/15.xxx)
Beispiel 4: 01.No Room In Frame (10.xxxx)
Hintergrund war, das mein Sonos System dadurch alles richtig sortiert hat.
Aber das "Ford Sync2" Soundsystem im Auto - ist jetzt neu - sortiert damit falsch.

Ich würde bei Beispiel 1 und 2 eine führende 0 brauchen - aber nur bei Titei 1-9,
denn wenn ab Titel 10 auch eine 0 vorangestellt wird, sortiert der Ford wieder falsch.
Beispiel 3 und 4 funktioniert.
Ich habe auch getestet - für den Ford brauche ich die richte Nummerierung in "Titel" nicht in "Track".

Das ganze kann nur dann angewendet werden, wenn ich die Modifikation auch über Besispiel 3 und 4 laufen lassen kann - und es dann noch funktioniert - denn ich kann ja am NAS nur die geamte Bibliothek auswählen.

Es würde mich echt freuen, wenn mir wer helfen könnte.
Danke im Voraus
Gruß
lotus78


#2

du könntest ja nach den Dateien filtern:

NOT %title% MATCHES "^\d+"

Und dann könntest du die 0 hinzufügen mit Konverter>Tag-Tag für TITLE
Format String: 0%title%


#3

@ohrenkino
Danke - das muß ich jetzt erst mal auf die Reihe kriegen und testen.
Ich gebe dann Feedback.
lotus78
Update:
Wenn ich den Filter eingebe, kommt keine Ergebniss - also es wird keine Datei mehr angezeigt.
(Filter -> Feld:TITLE - Filter: NOT %title% MATCHES "^\d+"


#4

Ich verstehe nicht so ganz was du meinst mit

Reden wir wirklich vom TITLE oder vom Dateinamen?
VIelleicht hilft ein Bildschirmabzug ... für die Ermittlung des Filterausdrucks


#5

Das wäre der Screenshot:



#6

Ach das war das Problem: du hast noch Mp3tag 2.42 mit der alten Filtersyntax.
Es wäre vielleicht wirklich gut, auf die aktuelle Version zu aktualisieren.
Von der alten weiß ich die Syntax nicht mehr.


#7

OK - stimmt - da war etwas.
Ich habe damals mit Absicht nicht abgedated - weiß aber nicht mehr warum...
Ich werde es mal mit der neuen SW versuchen - Feddback folgt.
Danke


#8

Ich habe jetzt MP3Tag 2.90a - mit Filter sehe ich dennoch keine Dateien.
Muß ich die MP3 Files auch irgendwie "hochziehen" ?


#9

Vielleicht ist dieser Filterausdruck besser:
NOT %title% MATCHES "^\d\d"


#10

SUPER - das schaut hier mit meinen Test Files (zwei CDs) richtig gut aus!
Jetzt muß ich noch am NAS selbst schauen.
Ich melde mich morgen -
Vielen Danke für Deine Mühe!
Gruß
lotus78


#11

Perfekt - alles bearbeitet - funktioniert!
@ohrenkino
Nochmals DANKE für Deine Hilfe!
Gruß
lotus78