%track% format


#1

Problem->

Vorgabe-> 01 Interpret - Titel.ext

FormatString-> %track% %artist% - %title%

Ergebnis->

track: 01
artist: Interpret
title: Titel

früher war der track dann = 1 heute = 01
wie lautet die lösung, sodas track wieder = 1 ist?


#2

Dasselbe hab ich mich heute auch gefragt. :frowning:
Wäre schön, wenn das einstellbar ist sonst müsst ich wieder ne alte Version benutzen.


#3

Im Moment ist dies nicht möglich. Allerdings könnt ihr nach dem Import der Tags aus dem Dateinamen nochmal mit dem Tracknummern-Assistent [STRG+K] über die Dateien gehen, so dass die führenden Nullen aus dem Tracknummern-Feld entfernt werden.

Viele Grüße,
~ Florian


Tag - Dateiname und führende Nullen?
#4

oder ihr macht eine neue Aktion Ersetzen mit regulären Ausdrücken
Feld: TRACK
Regulärer Ausdruck: ^0
Das untere Feld leer lassen
die enfernt jede Null aus dem Track Feld die am Anfag steht


#5

Problem-> gelöst

ist eigentlich nicht die schnellste lösung aber es geht.
DANKE!


#6

altenThreadwiederHervorhol

Wird es dafür irgendwann eine Option geben?
Also dass bei "Dateiname - Tag" die Tracknummer OHNE führende Null gespeichert wird?

Habe die Suchfunktion benutzt aber keine Lösung für das Problem gefunden.
Mit STRG+K geht es zwar, ist aber auf Dauer umständlich.

Gruss
Quimby


#7

Du kannst eine Aktion erzeugen, die die führende Null löscht (mit "$num(%track%,1)").