tracknumbers not converted into 0x


#1

Hi,

When selecting only one track with a track-number-tag set to "1" instead of "01", the tag is updated (when saved) to "01".
That's ok, I like that feature.

But, when selecting more than 1 track with a track-number
tag set to "1" (or 2, 3, etc.), the tags are not updated to "01".

Using v2.15, English, on Windows 2000 prof.

Regards,

Geert


#2

Hi,

that's because when selecting multiple files the track-number edit field is set to . Setting a field to means that this field is not even touched when saving tags.

If you want to reformat track-numbers of multiple files use the Auto-numbering wizard (Ctrl+K) instead.

Not a bug.

Regards,
~ Florian


#3

Auto-Numbering Wizard works well if your selection is sorted in the order the count will be...

but if the sorting is mixed, ANW will change the track number.

It would be nice if ANW would could also have an option to only check if a single-digit exists in the track field, and place a 0 in front (or subtract it)... rather than using a blunt method of making a brand new count across a selection of files starting from the top as 01.


#4

Simply sort the files by the existing tracknumber via View, Sort by, Track and apply the Auto-numbering wizard on the sorted files.

Best regards,
~ Florian