Trapping chars in tags not to export (!,`,~)


#1

Is there a way to look for these chars and just drop them from the output stream on export only?

My importer doesn't like special chars even if supported by the OS.

Examples:

BEL BIV DEVOE - WORD TO THE MUTHA! - WBBD - BOOTCITY! THE REMIX ALBUM - 12 INCH VERSION

Need to drop the !

BRANDY - SITTIN' UP IN MY ROOM (DOUG RASHEED REMIX) - SITTIN' UP IN MY ROOM - 12 INCH VERSION

Need to drop the '

Parentheses seems to be no issue.

How can this be done?

Thanks

Chris


#2

http://pages.citebite.com/w4k0q4q7agxu


#3

I've tried several iterations like:

$replace(%artist% - %title% - %album%,',).jpg;

But it still puts the ' in there on the output. i followed this _ > -. I'm trying to just get the ' to drop without adding a space. With this all I get on the output is .jpg nothing else.

Am I missing something?

Command: $replace(string,from,to) or $replace(string,from1,to1,from2,to2,...)
Example: $replace(%artist% - %album% - %track% - %title%,_,-)
This example replaces all underscores to dashes. You can provide additional pairs of from/to as parameters.


#4

I figured it out, it was a special functionality character that I needed to add to disable raw parsing:

$replace(%artist% - %album% - %track% - %title%,'',,!,).jpg

Need to add '' not just '.......reading the manual clearly helped!

Greetz