Two questions about Convert.

Hello,

I have tried to use the "Convert" on MP3TAG, but I got 2 problems.

1. How to add the Convert to the Action, coz I have more than one Convert to do.
For example:

I want to covert "text file - tag" for twice, one is for title, another is for genre.
So, I have to do an action, that will be much faster.

2. How to convert "tag - file name" if I want to add an zero before the file names (only from track 1 to track 9).
For example:

I have 15 songs import to MP3TAG, all of them have right track number tags. But the files have no track numbers. So I want to convert the track number to file name. If I do the format string: "0%track% %title%", there will be an zero in front of the file names start from the 10th file like the list below:

01 Heartbeats1
02 Heartbeats2
03 Heartbeats3
04 Heartbeats4
05 Heartbeats5
06 Heartbeats6
07 Heartbeats7
08 Heartbeats8
09 Heartbeats9
010 Heartbeats10
011 Heartbeats11
012 Heartbeats12
013 Heartbeats13
014 Heartbeats14
015 Heartbeats15

So, how to do the covert as I want (Only have zero from track 1 to track 9)?
And I also want to do this as an action if it can be.

Thanks for help!

1: there is an action for that, see the list of actions "Import text file".

2: instead of plain %track% use $num(%track%,2)

If you want to do more than 1 action in a row, you cannot use the convert-menu but you have to define action-groups with the action-menue.
But anyway you can try out the format values with the convert-menue first because there you can see the result as a preview.

$num(%track%,2) - %title%

Hello, thanks for helping me.

But I still have problem with the first one.
I tried to use "import text file", but it doesnt work the same as "text file - tag".
All the names in the list just write into every title. I have no problem to use "text file - tag", that's why I asked this question.
Please check, thank you.

Unless you specify a filename for each record in an import file then the first record gets imported into the current file.
I still wonder, what good that workflow would do and if not a "Format value" action would be much better.
But you have not told us how the import file looks like.

I don't know what do u mean, can you please check the files to have a try?

With these files, when I use Convert - text file - tag, it will be OK to get the title.

When I use the action "import text file", it doesnt work.

Thanks in advance.

Test_Files.zip (1.46 KB)

And you only get "Heartbeats" written into every title, right?

So, what you would have to do is to create a text file with something like
1;Heartbeats
2;Ultraviolet
3;Sparks
4;Shimmer
5;Snow
6;Bright Eyes

and for the import fields in the action you have to enter:
_FILENAME;TITLE

Otherwise the problem is, that mp3tag executes each action for each file but does not know how many files are in the selection to generate some kind of offset. This only works for the converter.

So to get the action to work you either have to create a single textfile for each track that can be addressed by some kind of fieldname in the music file or you have to define inside the textfile which record belongs to which music file.

All in all, I would say, is this a very cumbersome way to get the data into the files. That is why I asked whether this workflow is really worth it.

Hello,

When i tried that, all the names go to every title like: HeartbeatsUltravioletSparksShimmerSnowBright Eyes

And I have tried your way, it doesnt work.
Nothing happens to the title tag.

And this is the easiest way I can do, coz mostly of the file names and titles are not right.
Only the names in the tracklist are right.

No, sorry, I was not quite accurate:
The action to import data only works for 1 field with 1 file.
So you have to create a separate text file for each music file.
So for the file 1.mp3 there has to be a corresponding file 1.txt.

If you want to use the tracklist with records for several files then you have to use the converter.

There is nothing on the actions area like the converter "Textfile -Tag".

If you want to try harder, then you have to write some action calls to simulate the converter.

You can import the entire list file into one tag-field by an action call, ...
then do a search within this tag-field, maybe using a regular expression,
through the imported text lines, and find a matching line for the current underlying file.
Then just trim all other not related text lines from the tag-field, ...
or copy the one text line to another helper tag-field.
Then use an action to split the content of the helper tag-field and distribute the parts into their particular tag-fields.
In the end remove the helper tag-fields.

DD.20131118.2116.CET

Thanks for the help, but it's really difficult for me.
Can you please write an action group to help me solve this problem?
I've tried to fix this issue I got for days :frowning:

And I want to use "Textfile -Tag" for twice for one album.

Here is the test files. Thanks again.

Test_Files.zip (1.46 KB)

Hm, yes, this seems to be a simple task, because the tracks have set already their track numbers and the given input list is sorted by track number and contains just a single item per track.

Begin Action Group 20131118.lucas.import

Action #1
Actiontype 14: Import text file
Field __: TMP1
Filename: 'T:\TEST\tracklist.txt'

Action #2
Actiontype 5: Format value
Field ______: TMP2
Formatstring: $regexp(%TMP1%,'\r\n','\\')

Action #3
Actiontype 5: Format value
Field ______: TITLE
Formatstring: $meta(TMP2,$sub(%TRACK%,1))

Action #4
Actiontype 9: Remove fields
Fields to remove (semicolon separated): TMP1;TMP2

End Action Group 20131118.lucas.import (4 Actions)

Note:
This method allows an input list of maximal 1024 lines, due to the restriction of the function $meta.

DD.20131118.2250.CET

Thanks!!! It works perfectly!
You really helped me out. :laughing:

Hello,

I found a problem about the action:

When there are some special letters like: à, é... in the file name,
it will show garbled in the title tag. The name in the text file has no problem.

Is there anything wrong with the action codes or it's a problem from my computer?

Thank you.

This actiongroup works on ID3v2.4 tags without any known error.
This actiongroup just reads all the lines from the given text file into one tag field.
Then the given track number is used to fetch out the specific line from the tag field's content.
There is no character conversion involved.
The filename of the text file itself does not matter.

Please check again.
Maybe the content of the text file got bad characters when it was created.
Perhaps you are confusing something.

DD.20131121.1345.CET

Sorry, maybe it's because I use ID3v2.3.

I'll try again.

Thank you. :slight_smile:

Hello, the problem is still there, this is the test files I got for you.
Please check if it's ok for you to do the action.
For me, if I do that, the title will show the disordered code.
I even tried my language, and it has the same problem,
so it's not about if I have the language pack on my computer or not.

Appreciate your help :slight_smile:

Text_Files.zip (1.78 KB)

It is not a problem with the action group but with the character encoding in the given input text file and the environment on your computer.
The tracklist file which you have provided has a UTF-16LE character encoding.
I am of the opinion, that this file has already garbled text.
And obviously there is a language involved with right-to-left orientation or east-asian characters.
Both I cannot test on my machine.
I've tried to import an UTF-8 encoded text file, which contains a copy of the given filenames and this works.

So try to create a text file with UTF-8 encoding, having this content ...


... and the import into the TITLE tag field should work.

DD.20131201.1139.CET


The text file looks fine.

lucas please check Options > Tags > Mpeg
that you have ID3v2.3 utf-16 or ID3v2.4 utf-8 selected to be able to save unicode characters in the tag.

Thanks, I got it. It's because I use notepad++ and it's not UTF-8.
Now everthing works fine.

Appreciate your help. :slight_smile: