Unable to open .jpg files fixed , then can't write tags

So I installed Mp3tag after reading on a photo website that it can also edit .jpg flies tags.
Worked great, i could darg and drop files into the window and they would load up....i'd add a comment to the meta data. save and all was well.

Then the other day I couldn't drag and drop files into the program any more. I would just get a "reading directory.." message that would flash on the screen for a microsecond. I seemed to have fixed that as under options there is "Restrict incoming files to" so I added *.jpg; Now I can open them again. Strange it worked fine from the start but then stopped.

So now I can open the files again but when I save it says "Writing tag data" but it really doesn't save. The "Comment" text box gets cleared. I'm not using any strange characters and its just 1 word.

I tried running the program in administrator mode.
Tried uninstalling and deleting the data folder thru the uninstall program.
Did again and verified the program folder was empty before reinstall.
Tried installing the 32 bit version, tried running a old version I found thru Google.

I'm not sure what happened? Any ideas?

I would be a better idea to read MP3tag's feature page:

You will not find jpg files as supported file formats.
For jpgs you can only modify the filename.

Thank you Ohrenkino.
I swear it worked for some time. I'm not nuts! :slight_smile:
I appreciate the documentation proof though.

So I've got a new program for others if they are in need and see this thread later.
GeoSetter, its mostly for GPS writing to images but it can read all meta data in do it in batches.

Which site led you astray?

Whew took me a bit to find it but finally found the site that lead me this direction :slight_smile:

Now that I re-read the link it it does say on the title its for Mp3.... :unamused:
I think I had searched Google for something like
"jpg metadata editor" and it took me here.

Item #2 on the list