Unable to REMOVE cover art

Remove cover art is not working in latest version. "Right click... Remove cover..." appears to work, until the files are saved once again, and the cover image reappears.

As you see the filename next to the cover thumbnail in the tag panel, you see the representation of the file in the folder.
If you do not like that, see the Options Ctrl-O >Tags> Do not show covers from the folder.

If you want to be sure, you could also apply a filter
%_covers% MISSING
to see files without embedded picture
%_covers% PRESENT
to see the files with embedded picture.

It also can be a cover description (likely from an APEv2 tag), which I think is more likely in that case. The file would not display the cover type "Front Cover".

@twsf, my guess is that the tag version displayed doesn't match the tag version saved. See the Tags column in the File List and Options → Tags → Mpeg for configuration.

I am trying to remove and replace with a new, larger cover image, and it doesn't work. It keeps resaving the old, smaller cover image., even when I click "don't save old cover".

Could you check the extended tags dialogue Alt-T for a single file and have a look at the dialogue title whether that says anything with APE?
If so, could you then check the option Ctrl-O as @Florian recommended?

If you read APE but do not write them then the APE tags will stay unmodified but you will always see them.

Here are what the screens show for one file, and the program settings:


I see an inconsistency in the two Options screens - why would they be able to have inconsisent checks in APEv2 setting? Or is the second screen ("Ape, Mpc...") irrelevant?

Regardless, when I do tick "Write APEv2" in Mpeg Options settings (which I unticked per Support directions when trying to solve a different problem), I now can correctly remove and replace the cover. Although, if it's helpful to developers, the screen still says "Front Cover" as cover type:

That depends.The documentation says:

"These configuration options are affecting audio formats which are using APE tags by default (like Musepack, Monkey’s Audio, WavPack, …)."
Which means: not MP3 or MP4 files.

If APE tags cause so much of a problem, I would remove them and use only ID3 tags. Or do they contain data that you need?

My question was why MP3Tag would have two adjacent setting screens that would allow CONFLICTING settings?

My answer was that the 2 setting screens apply to different file types - so there is no real conflict.
Options>Tags>Mpeg applies to files ending in "mp" in most cases,
Options>Tags>Ape, Mpc applies to files of the type Monkey’s Audio, WavPack etc.

So, the settings are only used for file types that fit. If you have no i.e. WavPack files, then the settings Options>Tags>Ape, Mpc are ignored.
Also, if you have FLAC files, none of the settings for MPEG or APE, Mpc are taken.
And so on.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.