Uncheck Auto-apply filter has no effect

I have Auto-apply filter unchecked

When I click F3 to display the filter box, it automatically applies the last filter, which can take a long time

Also, if I fat-finger and hit page-up or page-down instead of an arrow key, it automatically executes the filter I've paged to, which, again, can take a long time.

It would also be nice if, when I accidentally change the filter I'm working on, if I could hit ctrl-Z and get back to what I was working on.

I don't know what you do - but I tried a filter with the unchecked option for auto-apply and it worked as expected: the filter only became active once I pressed Enter.

I checked for updates. I was using 3.04a. I upgraded to 3.05 and haven't had a chance to see if the issue is resolved with that release.

In any case, it would still be nice to be able to undo accidental navigation through the history