Using Text File to Add Cover Art?

I am using the Text file converter to do batch stuff and it's working great. Is there a way I can have it look at my hard drive for a specific cover art file (jpg) and automatically put it in?

Example Line from my Text File:
SongTitle\MyAlbum\MyArtist\97\MyPublisher\Composers\BandURL?????????????\Comments

Here's my string I am using:

%title%\%album%\%artist%\%bpm%\%publisher%\%composer%\%wwwartist%\%_covers%\%comment%

The ???????????? are what I am asking about...My jpg is on my C:\Logo.jpg

Will this work?

Thanks!!!

To import a cover you need to use an action [Alt+5] "Import cover from file"
and enter the path to the cover there.

If the path is only in that text file, you can import the path to a tag field and use that tag field in the Import cover action.

change your string to
%title%\%album%\%artist%\%bpm%\%publisher%\%composer%\%wwwartist%\%coverpath%\%comment%

and use %coverpath% in the import action.

Good idea to use a temporary user defined tag field for holding and providing the filepath of the cover image file for later importing the image file.

Hmm, if %coverpath% carries a filepath including backslashes, then OP Fridayspast will going into trouble. He will need to change the Backslash separator of the import format string to a different but unique character, e. g. the Star symbol * or the Pipe symbol | or something else character.

DD.20100506.1235.CEST

Hey guys, thanks for the replies...

Using the Import Cover File works great, of course. But, I'm trying to get it all in one action. The Alt+4 Text File -Tag action.

Example Line from my Text File:
SongTitle\MyAlbum\MyArtist\97\MyPublisher\Composers\BandURL\C:\MyPic.jpg\Comments

The problem is C:...That backslash messes it up. I tried using another character as suggested but that didn't work, it just takes this as text and imports that line, but nothing happens. I was hoping I could put "" around it or something so it knows this is a PATH to the Cover Art to import not text...

Any other ideas?

Thanks!!

No, why?
Dano's proposal will work as expected when respecting my proposal to adapt the separator character to the new situation.

The convert procedure "Text file - Tag" can only import textual data from a prepared column oriented text file.
The action "Import cover from file" can import binary data from an image/picture file.

Dano's proposal is ... to set a user defined tag field %COVERPATH% with the actual filepath to the cover image file.
After setting the tag field %COVERPATH%, then in a following step, the action "Import cover from file" can use the content from this tag field as the format string for the image file, which should be loaded as a cover image into the current track file.

A sample line of your text file should look like following:
(To avoid problems due to space character the filepath should be enclosed in double quotes.)
SongTitle|MyAlbum|MyArtist|97|MyPublisher|Composers|BandURL|"C:\My Folder\My Picture.jpg"|Comments

The related import format string should look like this:
%title%|%album%|%artist%|%bpm%|%publisher%|%composer%|%wwwartist%|"%coverpath%"|%comment%

DD.20100506.1856.CEST

If anyone reply to this and confirm that the above steps are correct? Because i follow the steps and the image do not appear in the tracks.
So if i understood correct:

  1. We go to Mp3Tag and we create a custom column with name = Coverpath, Value = %coverpath% and Field = %coverpath%

  2. In the txt file we format it as above SongTitle|MyAlbum|MyArtist|97|MyPublisher|Composers|BandURL|"C:\My Folder\My Picture.jpg"|Comments

  3. The import format string must be as above
    %title%|%album%|%artist%|%bpm%|%publisher%|%composer%|%wwwartist%|"%coverpath%"|%comment%

And finally after the upload the image should be visible in each track, without the action drag and drop the image or import with shortcut Alt+4. Is this correct?? Because the image is not displaying, probably i'm doing something wrong.

I do not see the 4th step:

Yes i forgot the forth step. After all the above i go to convert and click Text File - Tag and import the txt file with above format. But the image do not display. Is it possible, if you have the time to upload some image with the configuration or steps how you do it. Thanks in advance.

The cover will appear only after you have started the action "Import cover" with the reference to the user-defined field in the format string.
Simply importing the data from the text file is not enough.
If you are looking for the link to the cover, check the extended tags dialogue (Alt-T) to see if the field is there and whether it has the correct contents.
Then create the action to import the cover with
Format String: %coverpath%.jpg
provided, the user-defined field for the link is called COVERPATH.

ah understood i need to create a new action importing the cover image base the path. Thank a lot man

One last question is it posssible to set for this action a shortcut??? e.g. Alt+Key something?? I mean the specific action not the Alt+6 for all the actions

If you use an ampersand in the action's name, i.e. &1 Import Cover you can call it by pressing Alt+a and then 1