V2.89 tags fehlerhaft nach Eintrag


#1

ich bin DJ, und tagge die tracks für iTunes/Traktor für die jeweilige Kategorisierung/Einträge dort.
viell. ist der Bug in einem neueren built schon behoben. k.a.
wenn ich das comment field editiere bei einzelnen tracks in einem Album, wird das "Country" und "Source" field vermurkst. Am besten zu sehen auf den Screenshots.
pic 1 tag korrupt, pic 2 so wie er sein sollte eigentlich.
Das ist jetzt nicht so weltbewegend, aber ich wollte das loswerden.
Ich habe dazwischen wohl ein mp3tag proggie update gemacht, von daher kommt das wohl. Wenn man auf eine neue Version umsteigt, wird in den angesprochenen Feldern, die von der alten Version geändert wurden, die tags fehlerhaft, bzw. überschrieben.
danke.


#2

Tritt der Fehler nach dem Editieren der Tags in Mp3tag oder iTunes/Traktor auf?

Könntest Du mir eine Testdatei (oder einen Dropbox-Link) per Mail zuschicken?


#3

eigentlich kein Problem,
ich denke SOURCE u. COMMENT sind "Blob" fields soweit ich weiß, nur bei denen tritt das auf.
PUBLISHER; GENRE ja nicht, die werden nicht corrupt...


#4

Das hab ich gar nicht geschaut, ob das nur in mp3 tag so ist.
Der Fehler tritt nach der Aktualisierung auf eine neue mp3tag version auf, wenn ich die entsprechende Datei dann im aktualisierten mp3 tag öffne, hats die "Blob" Felder geschrottet.
Ich bearbeite NUR mit mp3tag Dateitags, sonst mit keinem anderen Editor. Da kommt es sonst vermehrt zu fehlerhaften oder nicht angezeigten Tags.
Du brauchst nur eine Musikdatei wo der Fehler auftritt?
die von dem Screenshot hab ich schon korrigiert :-/
wenn ich nochmal eine find, dann kriegst eine mail mit Anhang.


#5

Vielleicht wäre es einfacher, so eine Datei vor Ort auf Integrität zu checken mit einer der gängigen Utilities wie MP3diags, MP3val und/oder foobar2000.
Denn: ich kann sehr wohl ein Feld vom Typ COMMENT anlegen, ohne dass es zu der von dir gezeigten Ausprägung kommt.
Source scheint mir dagegen ein benutzerdefiniertes Feld zu sein. Aber auch benutzerdefinierte Felder kann ich ohne Probleme anlegen und erneut anzeigen lassen.


#6

foobar hab ich hier am laufen, kann ich checken wenn ich nochmal defekte Tags finde.


#7

in foobar2000 ist der Tag Eintrag ebenfalls defekt, hab jetzt eine datei gefunden, ich schick sie zu.
%catalogid% und %country% sind kaputt, wenn man die Tags geändert hat, und dann irgendwann ein update macht.


#11

Deine Mail ist hier nicht angekommen, auch nicht in meinem Postfach bzw. Spam-Ordner. Schick mir den Link doch einfach via PM im Forum


#13

Ich hab die Datei bekommen, jedoch ist sie bereits fehlerhaft (es steht beispielsweise OUNTRY im Feld COUNTRY).

Ich daraus leider nicht ablesen in welchem Zustand die Datei vorher war — wenn Du das Original noch hast, bin ich natürlich daran interessiert.


#16

Ich sehe weder "Country" noch "Catalogid" noch "Source" in dieser Datei.
(Keines dieser Felder ist übrigens ein Standardfeld, sondern es sind alles benutzerdefinierte Felder - könnte es sein, dass ein anderes Programm in deinem Workflow mit benutzerdefinierten Feldern Schindluder treibt?).
Was ja mal interessant wäre: was sagen denn die Check-Programme über die neuen Dateien bevor sie bearbeitet werden? Sind die OK?


#17

sorry, die posts waren für die pm bestimmt. Nein da treibt nix Schindluder, da ich ausschließlich mit mp3tag tagge.


#18

Woher kommen denn die Einträge für Country etc.?
Im Screendump finde ich die nicht. Sind die nicht in allen Dateien vorhanden?
Der Screendump zeigt meiner Ansicht nach keine fehlerhaften Felder.

Was mich fasziniert: wieso wendest du nicht mal MP3diags und/oder Mp3val auf deine Sammlung an?
Die haben einen Scan-Mode, der nichts verändert, aber Fehler zeigt.
Wenn du dann so eine fehlerhafte Datei gefunden hast, kannst du sie ja mal schicken. bzw. eine Kopie anlegen und mit MP3tag bearbeiten und sehen, ob der Fehler wie zuvor von dir geschildert, auftritt.
Und dann schickst du mal die Originaldatei.


#19

die Fehler treten NUR bei den Dateien auf, deren tags ich SELBST editiere, und dann irgendwann später mit einer aktuelleren mp3tag version öffne. Da ist vorher nichts defektes dran. Das liegt einzig und allein an mp3tag. Die blob fields sind eh nicht so entscheidend, aber das ist mir eben aufgefallen. Das ist alles.


#20

Genau das würde ja die Überprüfung mit den schon mehrfach genannten Dienstprogrammen belegen.
Meine Überlegung war: wenn die Dateien doch nach deiner Auskunft zuvor nur mit MP3tag bearbeitet wurden, diese Dateien den Fehler auch in anderen Programmen wie Foobar zeigen, dann müssten diese Dateien doch als fehlerhaft auffallen.
Umgekehrt: wenn die Überprüfung der Dateien keinerlei Auffälligkeiten zeigt, dann müsste doch eine weitere Überprüfung dieser Dateien in z.B. Foobar jeweils die richtigen Daten zeigen. Denn zuvor war doch alles in Ordnung, sagst du.
Und wenn du dann die Kopie so einer Datei mit richtigen Daten in die neue Version von MP3tag lädst, müsste doch der Fehler sofort sichtbar sein und du könntest genau diese Datei zur Verfügung stellen für weitere Analysen.
Wenn sich allerdings beim Check der Dateien herausstellt, dass da doch welche kaputt sind und ausgerechnet diese zu dem Fehlerbild führen, dann wäre zuerst eine Korrektur der Dateien angesagt.

Eine Fußnote: ich habe für "blob" als Erklärung "binary large object" gefunden und das im Zusammenhang mit ID3-Tags für die eingebetteten BIlder. Benutzerdefinierte Felder sind nach meinem Verständnis Felder wie alle anderen auch und meistens Text und nicht binär.
Und noch eine Fußnote: ich habe mehrere zehntausend Dateien mit Mp3tag vermutlich seit der Version 2.42 bearbeitet und nie das von dir beschriebene Fehlerbild bekommen. Was ich allerdings gefunden habe: je nach Quelle gab es die unterschiedlichsten Macken in den Original-Dateien, die mit den Dienstprogrammen aber gut identifiziert und meistens auch korrigiert werden konnten. Dateien, die ok sind, lassen sich auch meistens fehlerfrei mit Metadaten versehen.