Weird things happening with the Year field


#1

I'll use the / to separate the original release year from the remastered/re-released year eg "1974 / 2009". It didn't work yesterday work for a while today and no it's stopped again.

Any idea to what the problem may be?


#2

Mp3tag use the "\\" for defining Multiple Values and not "/"

Edit: *\ Something strange, I can't seem to add a MultiValue tag with "\\" for Year, no problem doing this for genre, but not year !

Here screenshots of adding the Multvalues


And here the extended Tags after Saving





#3

The origin for the detected behaviour seems to be there ...
"History of changes"
[2012-10-24] REL: VERSION 2.53 (for Windows XP/2003/Vista/2008/7)
[2012-09-29] CHG: ID3v2.3 TYER/TDAT now merged into one YEAR field formatted as YYYY-MM-DD.

... and see also ...
http://id3.org/id3v2.3.0

DD.20130206.0454.CET


#4

I copied this out of one that I didn't earlier today that worked "1986 / 2008".


#5

I did some tests just with Year Field to satisfy my curiosity. (Note only used mp3, with ID3v2.3 and ID3v1 and very important Mp3tag Version 2.54 !!)

2010/2011 result Year Empty
2010//2011 result Year Empty
2010 / 2011 result Year Empty
2010 \ 2011 result Year Empty
2010\2011 result Year Empty
2010\\2011 result Year only contains 2011
2010-01-01\\2011-01-01 result Year only contains 2011-01-01
2010,2011 result Year Empty
2010 , 2011 result Year Empty
2010 2011 result Year Empty


#6

OK if this helps the / separating the years returns a blank field in mp3 but works correctly for flacs.