what is the process of removeing "no" from song


#1

how to erase all track no begin from song names...



#2

"song names" is a very misleading. You are talking about "file names".

If all your files have proper ARTIST and TITLE tag fields:
Conveter: Tag - Filename
Formatstring: %artist% - %title%

If not:
Action: Format Value
Field: _FILENAME
Formatstring: $regexp(%_filename%,^\d+. *,)

or:
Converter: Filename - Filename
Mask over old filename: %1.%2
Mask over new filename: %2


#3

It is not quite clear if you refer to the TITLE which is a tag inside the file or only the filename which is the identifier for the file system
As it has a player symbol in front of the "name" it is problably the filename.
Tnere are several ways and for all you have to select all files that should be processed:
Suggestion 1:
preserve the data and import it into the tags with the converter "filename - tag"
and a mask like this:
%track%.%artist% - %title%
(Check the preview in that dialogue if the mask fits).
Then use the converter "Tag - filename" with the mask:
%artist% - %title%
This way has the benefit that you do not throw any data away but perserve int the tags.
Suggestion 2:
You have already filled the tags TITLE and ARTIST
Proceed like in suggestion 1 after you have filled the tags
Suggestion 3:
Use the converter "Filename - Filename"
Enter as source the mask:
%1.%2
Enter as target mask:
%2
The preview should help you.
Suggestion 3 hast the disadvantage that you will get rid of the numbers and will have an empty tag fields and will have lost the information for TRACK...
The choice is yours.


#4

FRIEND I AM TRYING 2ND METHOD OF YOURS

Converter: Filename - Filename
Mask over old filename: %1.%2
Mask over new filename: %2
[/quote]

THIS METHOD WORKS FIRST TIME WELL AND WHEN I TRY 2ND TIME THE PREVIVEW & OK ARE DISABLE... HOW TO ENABLE THIS BUTTONS....



#5

Well, you have to adapt your mask.
In the first example (the one that worked) the dot between the number and the rest was the separator that structured the filename.
This time there is no dot behind the number.
What I see is that a fair number of files start with a zero
So if you enter a source mask
0%1 %2
and as target mask
%2
the preview and OK should be active again.
The conversion will not work for all the files, though as they do not match the pattern.
You would have to adapt the pattern again (or come back and get the next suggestion).


#6

Dear ohrenkino

     i enter a source mask
     0%1 %2
     and as target mask
     %2
     the preview and OK should be active again. but when i click on ok 
     the conversion not work on the file names, and again previvew and ok are 
     inactive. 
     plz give me another pattern which works on  given two images....Thanks




#7

What? The OK button becomes active once and then it does not work again? I mean: once you have renamed the files they do not match the pattern anymore so naturally you can't run the renaming again.
Also: you have filled some tags with information that looks a lot like parts of the filename. So if you have trouble with the patterns, why don't you use the converter "Tag - Filename" with the mask
%title%
This should cater for the majority of shown files and leave only very few with a number in front.
You may then decide whether it is easier to rename them manually or dig deeper into the functions of MP3tag like filtering, converters and actions.
One more thing: the first file in the selection has to match the pattern. I cannot see the beginning of the selection in the screendumps so I cannot supply a mask. If you select only the files displayed in the screendump you should get a working OK button.
Also, you should take care that you only select those files that have a blank between the number and the rest of the filename.
A filename like
0012papi mix
will be renamed to
mix
Also files like
14 Genda...
will not be treated.