Why do titles are only partially displayed in windows 10?

#1

I imagine this is a windows issue, but if someone has a solution it would be nice. Long titles edited with mp3tag do not show in full in windows explorer, only partially. I don't remember this happening in the past. Please advice.

0 Likes

#2

Titles or Filenames?
MP3 or FLAC? Or which audio format?
Where in Windows? Properties dialogue? Windows media player?

0 Likes

#3

At the moment I can see it on flac files, in fields as title, contributing artist and album and in both windows explorer and wmp. Also, I checked properties and the same issue appears. But when I open the files with mp3tag, the full titles show correctly.

0 Likes

#4

see e.g. here for the problems that windows has with flac files:


It's a windows issue.

1 Like

#5

The link must have been removed. Is there a solution?

EDIT: I can see the link now. It seems complicated. I may look into disabling native flac and install the codec(?). I don't expect microsoft to fix anytime soon. They're not so good with the display of music and the native player is getting worse with every upgrade. Thanks a lot for the heads up.

0 Likes

#6

Reduce your long title length, then reconvert the FLAC to FLAC again by using FB2000. Sometime it works to let windows explorer display normally.

1 Like

#7

One more thing, if you have Art works display probrems in Windows. Try to reduce the Art work size to less than 1000 x 1000 also. and reconvert your FLAC file to FLAC again to has the tags rewrite.

1 Like

#8

Hi, when you say reduce length, you mean in the fields (eg Album), that are truncated or the name of the file? Because the names of files are not so long, but album titles cannot be shortened, without having the same effect as the one produced by windows themselves.

0 Likes

#9

I am not sure if we are discussing same Windows problem.

My experience in some FLAC files from DG. It has very very long Title or/and very long Artist, it also has 1280 x 1280 cover art imbedded. The Flac tags displayed normally by Mp3tags and FB2000. But some fields no show in Windows Explorer.

After reduce the long fields length, and reconvert the FLAC to FLAC again by using FB2000, All tags fields displayed normally.

Hope you will lucky to fix your problem.

1 Like

#10

My flac files don't have very big size art covers, but surely some album titles are long, like "Don't Say That I Ain't Your Man", which ends up being "Don't Say That I Ain't You". But I wouldn't like to shorten it, you see. It defeats the purpose of tagging. However, thanks for the suggestions, they may become handy at some point.

Tags show fine in mp3tag, so the info is there at least. Maybe if native flac is ever fixed they will appear again. Apparently you can only disable native flac tagging, but not native flac altogether. It mainly looks bad in wmp, which I use because it is the only player I have found with folder view in a similar way as windows explorer (not tree vew). I tried few others, but to me wmp folder view is the most convenient.

0 Likes

#11
2 Likes

#12

Thanks a lot for the info. I disabled native windows flac tagging and installed wmp tag plus and flac file tags display right now in WMP (but not in windows explorer). That should do it for the moment and hoping windows may fix the rest. All the best.

0 Likes