WMP12 kann tags nicht richtig lesen

Hallo,

habe Probleme mit WMP12.

  1. Bei einigen Liedern werden Tags (Titel, Interpret, WMP-Bewertung) im WMP 12 nicht gelesen, obwohl sie in MP3tag als auch in itunes lesbar sind.
  2. In WMP12 werden teilweise auch andere Cover angezeigt, als in itunes oder mp3tag.

Die Lieder haben den Tag-Format:

ID3v2.3 (ID3v1 ID3v2.3) oder
ID3v2.3 (ID3v1 ID3v2.3 APEv2) oder
ID3v2.3 (ID3v1 Lyrics3v2 ID3v2.3) oder
ID3v2.3 (ID3v1 Lyrics3v2 ID3v2.3 APEv2)

Bisher gemacht:

habe schon WMP12 deinstalliert + installiert, damit sich Bibliothek neu erstellt.
um die Tags auf einen einheitlichen Format zu bringen, habe mit mp3tag die Tags neu gespeichert (über Dateien markieren und speichern gem. Optionseinstellungen --> Lesen: I3v1 und ID3v2, --> Schreiben: ID3v2.3 UTF-16, --> Entfernen: ID3v1 und ID3v2 und APE)

Woran kann´s liegen?

Anm:
Dachte, dass WMP12 stabil läuft, der hat mir aber mal nach "Änderungen an Medieninformationen übernehmen" viele Tags (wie z.B. Cover, Album) "zerhauen". Konnte dies nur mit mp3tag und itunes wieder beheben, soweit ich bei 12.000 Titeln dies über Filter herausfinden konnte. Was jetzt noch versteckt ist, weiß ich natürlich nicht.

Schon mal danke für Eure Bemühungen
Vg rsol


Ach ja, der WMP12 ...
also: die Bilder werden im Pfad
%appdata%\Microsoft\Media Player\Grafikcache
gespeichert. Das Verzeichnis kannst du erstmal getrost löschen, denn die Bildchen legt sich WMP dann wieder neu an.

Wenn du Änderungen an Dateien hast und noch weißt, welche das waren, dann markiere diese Dateien in WMP, lösche sie NUR AUS DER MEDIENBIBLIOTHEK und wähle dann die Funktion

Extras>Erweitert>Gelöschte Bibliothekselemente wiederherstellen ...
Damit liest WMP die gerade gelöschten Dateien noch einmal ein und damit auch die Aktualisierungen.
Eigentlich soll ja WMP Änderungen selbst erkennen, wenn man zu überwachende Ordner angegeben hat. Aber nach meiner (und anscheinend deiner) Erfahrung hat WMP ganz eigene Auffassungen, was eine Änderung ist.
Dann: WMP (und Windows Explorer) zerschießt beim Bearbeiten von Tags alle benutzerdefinierten Tags. Da würde ich also NIE Dateien mit WMP bearbeiten.

Hallo Ohrenkino,
hat leider nicht geklappt. Sowohl

Dateien löschen und "gelöschte Dateien wiederherstellen"
und Graphic Cache löschen

Noch eine Idee?
Vg rsol

?? Wie? der Graficcache lässt sich nicht löschen? Wie das?
Wenn die Folder.jpg und albumartsmall.jpg noch falsche Daten zeigen, dann solltest du die aus deinen Verzeichnissen löschen.
Setze dazu zuerst die Attribute der jpgs auf "lesbar und sichtbar". Öffne dazu im obersten Verzeichnis deiner Sammlung eine Eingabeaufforderung.
Dort tipp ein:
attrib -h -s *.jpg /s
Dann kannst du im Explorer nach allen folder.jpg und albumartsmall.jpg suchen lassen und die löschen.
WMP legt die Dateien wieder an.

Dann check mal, ob die tags wirklich nur V2.3 sind.
Setze dazu nacheinander die Filter
%_tag% HAS APE
%_tag% HAS 2.4
Falls da noch was nicht-2.3.-mäßiges dabei ist, bitte ändern. Das müsste mit den von dir gezeigten Einstellungen gut klappen.

So, und wo ist jetzt noch ein Problem?

Hallo Ohrenkino,
den Graphic Cache konnte ich löschen, aber das Problem blieb bestehen, d.h. wohl auch nach Neuaufbau durch WPM12.

Cover:
Habe jetzt folder.jpg und albumartsmall.jpg gelöscht.
Einige Fehler sind behoben, aber bei mind. 2 Covern spielen die Cover noch immer verrückt. Keine Ahnung, was da los ist.

Tag-Version:
Bei %_tag% HAS APE werden viele angezeigt.
Folgende Formate kann ich in mp3-Tag erkennen:

ID3v2.3 (ID3v1 ID3v2.3) oder
ID3v2.3 (ID3v1 ID3v2.3 APEv2) oder
ID3v2.3 (ID3v1 Lyrics3v2 ID3v2.3) oder
ID3v2.3 (ID3v1 Lyrics3v2 ID3v2.3 APEv2)

Habe gedacht, dass wären alle V2.3-Tags. Wenn nicht, wie kann ich diese ändern?
Vg rsol

Wenn die EInstellungen aus dem Screendump noch gelten, dann ist das für (neue) Dateien gut und richtig.
Wende jetzt erneut den APE-Filter an.
Dann markiere ein Gutteil der Dateien und schneide die Tags mit den FUnktionen des Kontextmenüs der Dateiliste aus (Dateiliste>Rechtsklick>Tag ausschneiden)
Das entfernt jetzt alle Tags aus den Dateien - von daher sollten das nicht zu viele auf einmal sein - aus Sicherheitsgründen, falls was schief geht :frowning:
Dann fügst du sofort wieder alle Tags ein (Dateiliste>Rechtsklick>Tag einfügen).
Dann drücke 2x F3 (macht den Filter aus und wieder an) und die gerade behandelten Dateien müssten keine APE-Tags mehr haben - das war nur zum Überprüfen beim ersten Mal.

Das machst du mit allen Dateien in geeigneten Portionen.

Und dann legst du die WMP-Bibliothek neu an (Extras>Erweitert>Bibliothek neu anlegen)

Hallo Ohrkino,
erstmal vielen Dank für deine vielen Tipps !!

Ich habe alle APE-Tags ausgeschnitten und neu eingefügt, die haben jetzt alle das Format "ID3v2.3". Weitere APE sind nicht mehr vorhanden. Macht es Sinn, auch alle verbleibenden
"ID3v2.3 (ID3v1 ID3v2.3)" zu bearbieten und somit auf "ID3v2.3" zu ändern?

Habe WPM_Bibliothek noch nicht neu angelegt. Ich habe die Auswahlmöglichkeiten "Medienbibliothek wiederherstellen" oder "Gelöschte Bibliothekselemente wiederherstellen". Die Option "Bibliothek neu anlegen" ist bei mir nicht vorhanden. Bin noch unsicher, welche ich nehmen soll, da beim letzten Mal ja viele Dateien "durchgeschüttelt" wurden, sodass Tags und Cover teilweise nicht mehr stimmten. Welche soll ich nehmen?

Stand jetzt:
noch immer sind einige Titel im WPM ohne Bewertung und teilweise fehlerhaftem Cover, obwohl in itunes und mp3-Tag die Angaben richtig und identisch sind.

Sorry wenn ich nerve, aber ich will endlich einen reinen Datenbestand haben und die Ursache behoben wissen, damit es nicht wieder zu neuen Unstimmigkeiten kommt.

Wenn alle deine Abspieler reinrassig V2.3 verstehen kannst du das tun - ist aber nicht "besser", sondern mehr was für Puristen.

Ich meinte das mit dem "wiederherstellen". Eben die anderen Möglichkeit :wink:

Bei den Covern, die falsch sind ... tja, wenn das nicht zu viele sind, dann einfach mal das Album in WMP öffnen (so dass die Titel alleine gezeigt werden). Wenn da das Cover nicht stimmt, einfach eine der Dateien anklicken, rechte Maustaste fürs Kontextemenü und "Dateispeicherort öffnen" wählen, das macht den Explorer auf. Da kannst du dann noch mal explizit die folder.jpg und albumartsmall.jpg löschen (bzw. ansehen, ob die was falsche zeigen).
Wenn nicht: im WMP alle Dateien des Albums löschen - und zwar nur in der Medienbibliothek und nicht auch vom Computer.
Und dann sofort danach die andere Funktion in den Extras>Erweitert>Gelöschte Elemente wiederherstellen.
Mehr Schräubchen zum Drehen hat der WMP nicht, meine ich.
Ach so: und den Cache könntest du auch einfach so ab und zu mal löschen...

Hallo Ohrkino,

es ist zum Mäuse melken:

habe in WMP12 "Medienbibliothek wiederhergestellt" und jetzt habe ich ca. 400 neue Lieder ohne Bewertung, ohne Cover und zum größteil Teil sogar ohne tags! WMP12 zeigt nur noch den Dateinamen als Titel, die restliche Tags in den Liedern sind leer. Die Lieder haben den Tag-format "ID3v2.3 (ID3v1 ID3v2.3)".
Zum Glück scheinen die Dateien nicht als solches beschädigt zu sein (zumindest lt. itunes + mp3-tag). Habe zum Glück eine Kopie vorher gemacht.

Cache löschen hat dies leider auch nicht mehr behoben.

WMP12 verhält sich ziemlich chaotisch, so dass es mir schwer fällt. die Ursache zu lokalisieren.

Hast du noch eine Idee?

Man muss WMP nur vorgaukeln, dass die Teile neu sind.
Es kann aber auch sein, dass sie wirklich irgendeine Macke haben, die WMP daran hindert, die Biester vernünftig zu lesen.
Deshalb: lad dir mal Foobar2000.
Dann lade dir in Foobar2000 die bockigen Dateien*.
Die Dateien in Foobar2000 in der Dateiliste markieren und die Funktion des Kontextmenüs Utilities>Rebuild MP3 stream" wählen.
Daraufhin müsste WMP die neu gebauten Dateien noch mal lesen - und dieses Mal hoffentlich richtig.

*: Dazu baust Du dir in WMP eine Playlist (müsste ja über Album>Unbekannt ganz leicht gehen, die Dateien zu finden).
Die gefundenen Dateien markierst du alle und schiebst sie in die Spalte Wiedergabe.
Nimm dazu Datei>Aktuelle Wiedergabeliste speichern unter... mit dem Format m3u (und nicht wpl).
Und die Wiedergabeliste kannst du mit Foobar laden.

Hallo Ohrenkino,

habe das mit zwei Liedern ausprobiert:

  • in foobar2000 per rechtem mausklick "Utilities>Rebuild MP3 stream"
  • in WMP12 Datei gelöscht und anschließend "gelöschte Bibliothekselemente wiederherstellen
  • im WM12 bleibt das Ergebnis das gleiche
  • Anm.: auch in Foobar2000 werden alle "Properties" korrekt angezeigt.

Bleibt da nur noch eine Deinstallation von WMP12 mit anschließendem kompletten Verzeichnis löschen in Benutzer/Appdata/Microsoft/media player?

Nee, das würde, soweit ich es ausprobiert habe, nichts bringen, da WMP ja anscheinend immer an denselben Dateien Schluckauf kriegt.
Von daher müsste man mal diese Dateien einer näheren Untersuchung unterziehen.

Ich würde jetzt folgendes vorschlagen:
Lade dir Mp3val aus dem Internet (ist freeware).

Finde die bockigen Titel in WMP.
Erzeuge (wieder) eine Wiedergabeliste und speichere die Liste.
Lade die Wiedergabeliste in MP3tag.
Markiere alle Titel.
Wähle Kontextmenü>Tags kopieren
Öffne Mp3val.
Ziehe alle Titel aus MP3tag in MP3val und starte die Reparatur mit dem Zahnrad-Symbol.
Ich hoffe, dass mp3val nun etliche Dateien mit dem Attribut "Fixed" versieht (und nicht OK oder Problem).
Wenn mp3val durch ist, gehe zurück in MP3tag und wähle Kontextmenü>Tags einfügen (mp3val setzt manchmal die Tags auf V1 zurück - durch das EInfügen mit Mp3tag gehen die Infos nicht verloren).

Und dann guck, ob wenigstens die Dateien, von denen Mp3val "Fixed" behauptet hat, in WMP ok sind.

funktioniert nicht, Lieder lassen sich zwar reinziehen aber bei Zahnrad passiert nichts (not scanned, processing thread is still active)
liegt wahrscheinlich an meinem Win7 64 (lt. Internet-Recherche)

gibt es eine Alternative?

Das weiß ich nicht - vielleicht mp3diags (ist auch freeware)?

Mp3diags gäbe aber zumindest schon mal nen Hinweis, dass an den Dateien was faul ist. Mp3val wäre sonst eine elegante Methode, die meisten Fehler auch gleich zu beheben.

Mp3val wäre sonst eine elegante Methode

.. das scheint mir auch so. Habe ein paar Dateien getestet und einen Screenshot vom Scan bei gefügt. Es sind einige meldungen gekommen, aber was damit machen? Die Reparaturauswahl in MP3diags scheint manuell und nicht automatisch.
Kannst du was mit den Meldungen anfangen?

Einen schönen Heiligabend !

Danke gleichfalls!

leider war kein screenshot dran ... die Reparaturmethoden findest du in der rechten Hälfte der Werkzeugleiste (von 1..4).
Wenn z.B. Meldungen dabei sind, dass 2 Sorten Mp3-tags vorhanden sind, mag dies erklären, warum keine Bilder gezeigt werden. Das Bild wäre dann nur in dem einen Tag und WMP liest ggf. die falschen.

Eine Methode (relativ brutal) wäre, die bockigen Dateien erst in MP3tag zu laden, die Tags zu kopieren und dann mit z.B. EAC oder CDex noch mal kompilieren zu lassen. Dann die Tags wieder per Mp3tag einfügen. Und dann noch mal mp3diags fragen, ob noch was faul ist an den Dateien.

Upps, hatte den Sreenshot vergessen:


Nö, das sind eigentlich nur Schönheitsfehler.
Das mit ISO-1 würde ich beheben (Dateien in MP3tag laden, alle markieren, Tag-Felder kopieren, Tag-Felder einfügen)

Nach den Dateien ohne BIld kannst du auch in MP3tag filtern mit:
%_covers% IS ""
oder
%_covers% MISSING

Und nach den Dateien, die kein Frontcover haben auch:
NOT %_cover_type% HAS Front

Bei mir hat manchmal wieder foobar2k geholfen, dieses mal allerdings mit der Utility "Rebuild MP3 stream".
Ganz ehrlich: ich weiß nicht, warum WMP ab und zu so rumspinnt, aber er tut es. Da hilft nur Geduld und Spucke. :wink: